summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdm/kdm-3.5.0.ebuild')
-rw-r--r--kde-base/kdm/kdm-3.5.0.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/kde-base/kdm/kdm-3.5.0.ebuild b/kde-base/kdm/kdm-3.5.0.ebuild
index d2700790765f..b2c70e8a7ccf 100644
--- a/kde-base/kdm/kdm-3.5.0.ebuild
+++ b/kde-base/kdm/kdm-3.5.0.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdm/kdm-3.5.0.ebuild,v 1.4 2005/12/17 10:11:22 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdm/kdm-3.5.0.ebuild,v 1.5 2006/01/14 09:13:54 flameeyes Exp $
KMNAME=kdebase
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
inherit kde-meta eutils
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-${PV}-patches-1.tar.bz2"
+
DESCRIPTION="KDE login manager, similar to xdm and gdm"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="pam"
@@ -22,8 +25,13 @@ DEPEND="$DEPEND
$(deprange $PV $MAXKDEVER kde-base/kcontrol)"
# Requires the desktop background settings and kdm kcontrol modules
-# Avoid using imake (kde bug 114466).
-PATCHES="${FILESDIR}/kdebase-3.5.0_beta2-noimake.patch"
+src_unpack() {
+ unpack "kdebase-${PV}-patches-1.tar.bz2"
+ kde-meta_src_unpack
+
+ # Avoid using imake (kde bug 114466)
+ epatch "${WORKDIR}/patches/kdebase-3.5.0_beta2-noimake.patch"
+}
src_compile() {
local myconf="--with-x-binaries-dir=/usr/bin"