summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/homerun/homerun-1.0.0.ebuild')
-rw-r--r--kde-misc/homerun/homerun-1.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-misc/homerun/homerun-1.0.0.ebuild b/kde-misc/homerun/homerun-1.0.0.ebuild
new file mode 100644
index 000000000000..a496130ff09a
--- /dev/null
+++ b/kde-misc/homerun/homerun-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/homerun/homerun-1.0.0.ebuild,v 1.1 2013/05/28 15:57:46 johu Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+VIRTUALX_REQUIRED="test"
+VIRTUALDBUS_TEST="true"
+KDE_LINGUAS="bs cs da de el es et fi fr ga gl hu lt mr nl pa pl pt pt_BR ro ru
+sk sl sv tr uk zh_CN"
+KDE_MINIMAL="4.10"
+inherit kde4-base
+
+DESCRIPTION="Application launcher for KDE Plasma desktop"
+HOMEPAGE="https://projects.kde.org/projects/playground/base/homerun"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://kde/stable/${PN}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1 BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep libkworkspace)
+"
+RDEPEND="
+ ${DEPEND}
+ $(add_kdebase_dep plasma-workspace)
+"
+
+# Fails 2 out of 6, check later again.
+# With virtualx/virtualdbus it hangs
+RESTRICT="test"