summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/alsa-lib/alsa-lib-1.0.4.ebuild')
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.4.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.4.ebuild
new file mode 100644
index 000000000000..dd08ff529206
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.4.ebuild,v 1.1 2004/04/04 19:01:18 eradicator Exp $
+
+inherit libtool
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64 -sparc ~ia64"
+LICENSE="GPL-2 LGPL-2.1"
+
+IUSE="jack"
+
+DEPEND=">=sys-devel/automake-1.7.2
+ >=sys-devel/autoconf-2.57-r1"
+
+PDEPEND="!ppc? ( jack? ( =media-plugins/alsa-jack-${PV}* ) )"
+
+MY_P=${P/_rc/rc}
+#SRC_URI="ftp://ftp.alsa-project.org/pub/lib/${MY_P}.tar.bz2"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+RESTRICT="nomirror"
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ elibtoolize
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ #This alsa version does not provide libasound.so.1
+ #Without this library just about everything even remotely
+ #linked to previous versions of alsa-lib will break.
+ #Fortunately, libasound.so.2 seems to be backwards
+ #compatible with libasound.so.1 and a simple link
+ #fixes the problem (fingers crossed)
+ dosym /usr/lib/libasound.so.2 /usr/lib/libasound.so.1
+ dodoc ChangeLog COPYING TODO
+}