summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/dumb/dumb-0.9.1.ebuild')
-rw-r--r--media-libs/dumb/dumb-0.9.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/dumb/dumb-0.9.1.ebuild b/media-libs/dumb/dumb-0.9.1.ebuild
new file mode 100644
index 000000000000..4d7b2c093b07
--- /dev/null
+++ b/media-libs/dumb/dumb-0.9.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/dumb/dumb-0.9.1.ebuild,v 1.1 2003/03/10 09:19:08 vapier Exp $
+
+DESCRIPTION="IT, XM, S3M and MOD player library"
+SRC_URI="mirror://sourceforge/dumb/${P}.tar.gz"
+HOMEPAGE="http://dumb.sourceforge.net/"
+
+LICENSE="DUMB"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND="media-libs/allegro"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ make -f make/makefile.uni OFLAGS="${CFLAGS}" all || die
+}
+
+src_install() {
+ dodir /usr/lib /usr/include
+ make -f make/makefile.uni install PREFIX=${D}/usr || die
+
+ dodoc readme.txt release.txt docs/*
+ insinto /usr/share/${PN}
+ doins examples/*.{c,ini}
+}