summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libsndfile/libsndfile-1.0.10.ebuild')
-rw-r--r--media-libs/libsndfile/libsndfile-1.0.10.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/media-libs/libsndfile/libsndfile-1.0.10.ebuild b/media-libs/libsndfile/libsndfile-1.0.10.ebuild
index f09ac4214407..1742b3f351f9 100644
--- a/media-libs/libsndfile/libsndfile-1.0.10.ebuild
+++ b/media-libs/libsndfile/libsndfile-1.0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsndfile/libsndfile-1.0.10.ebuild,v 1.3 2004/07/19 09:35:10 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsndfile/libsndfile-1.0.10.ebuild,v 1.4 2004/08/01 06:09:07 chriswhite Exp $
DESCRIPTION="A C library for reading and writing files containing sampled sound"
HOMEPAGE="http://www.mega-nerd.com/libsndfile/"
@@ -13,8 +13,13 @@ DEPEND="virtual/libc"
src_compile() {
( use pic || use amd64 ) && myconf="${myconf} --with-pic"
- myconf="${myconf} $(use_enable static static)"
+ myconf="${myconf} $(use_enable static)"
econf $myconf || die "./configure failed"
+
+ # fix this weird doc installation directory libsndfile decides
+ # to something more standard
+ sed -e "s:^htmldocdir.*:htmldocdir = /usr/share/doc/${PF}/html:" -i ${S}/doc/Makefile
+
emake || die "emake failed"
}