summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/last-exit/last-exit-2.0.ebuild')
-rw-r--r--media-sound/last-exit/last-exit-2.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/last-exit/last-exit-2.0.ebuild b/media-sound/last-exit/last-exit-2.0.ebuild
new file mode 100644
index 000000000000..bbb1d9215305
--- /dev/null
+++ b/media-sound/last-exit/last-exit-2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/last-exit/last-exit-2.0.ebuild,v 1.1 2006/07/30 03:32:24 steev Exp $
+
+inherit mono gnome2 eutils
+
+DESCRIPTION="Gnome/GTK+ alternative to the last.fm player"
+HOMEPAGE="http://www.o-hand.com/~iain/last-exit/"
+SRC_URI="http://www.o-hand.com/~iain/last-exit/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=gnome-base/gconf-2.0
+ >=x11-libs/gtk+-2.6
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-base-0.10
+ >=media-plugins/gst-plugins-mad-0.10
+ >=media-plugins/gst-plugins-gconf-0.10
+ >=media-plugins/gst-plugins-gnomevfs-0.10
+ >=dev-lang/mono-1.0
+ >=dev-dotnet/gtk-sharp-1.9.2
+ >=dev-dotnet/gnome-sharp-1.9.2
+ >=dev-dotnet/glade-sharp-1.9.2
+ >=dev-dotnet/gconf-sharp-1.9.2"
+
+pkg_setup() {
+ G2CONF="${G2CONF} \
+ --disable-schemas-install"
+}
+
+src_install() {
+ make DESTDIR=${D} install
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ einfo "You will unfortunately, need to restart X for this to work properly."
+}