summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/dsniff')
-rw-r--r--net-analyzer/dsniff/ChangeLog6
-rw-r--r--net-analyzer/dsniff/dsniff-2.3-r5.ebuild77
-rw-r--r--net-analyzer/dsniff/dsniff-2.3-r6.ebuild48
-rw-r--r--net-analyzer/dsniff/dsniff-2.3-r7.ebuild14
-rw-r--r--net-analyzer/dsniff/files/digest-dsniff-2.3-r52
-rw-r--r--net-analyzer/dsniff/files/digest-dsniff-2.3-r61
6 files changed, 12 insertions, 136 deletions
diff --git a/net-analyzer/dsniff/ChangeLog b/net-analyzer/dsniff/ChangeLog
index dad88db29264..e75b126878cf 100644
--- a/net-analyzer/dsniff/ChangeLog
+++ b/net-analyzer/dsniff/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/dsniff
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.21 2005/10/15 09:34:08 mkay Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.22 2005/11/27 02:44:14 vanquirius Exp $
+
+ 27 Nov 2005; Marcelo Goes <vanquirius@gentoo.org> -dsniff-2.3-r5.ebuild,
+ -dsniff-2.3-r6.ebuild, dsniff-2.3-r7.ebuild:
+ Mark 2.3-r7 x86 stable, remove old ebuilds.
*dsniff-2.3-r7 (15 Oct 2005)
diff --git a/net-analyzer/dsniff/dsniff-2.3-r5.ebuild b/net-analyzer/dsniff/dsniff-2.3-r5.ebuild
deleted file mode 100644
index d9c02a730f2f..000000000000
--- a/net-analyzer/dsniff/dsniff-2.3-r5.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3-r5.ebuild,v 1.1 2005/06/27 19:20:26 vanquirius Exp $
-
-inherit eutils flag-o-matic
-
-# dsniff needs to build it's own version of sys-libs/db, since the one
-# normally installed is for some reason unusable for dsniffs configure script.
-# The version is chosen as being the standard one around at the time i wrote
-# this ebuild, it's not set in stone.
-
-DB_VER="3.2.9"
-
-DESCRIPTION="A collection of tools for network auditing and penetration testing"
-HOMEPAGE="http://monkey.org/~dugsong/dsniff/"
-SRC_URI="http://www.sleepycat.com/update/snapshot/db-${DB_VER}.tar.gz
- http://monkey.org/~dugsong/${PN}/${P}.tar.gz"
-
-# dsniff has it's own small license which is in the docs section
-LICENSE="DSNIFF"
-SLOT="0"
-KEYWORDS="~amd64 ~alpha ~ppc ~x86"
-IUSE=""
-
-RDEPEND="virtual/libpcap
- <net-libs/libnet-1.1
- >=net-libs/libnet-1.0.2a-r3
- >=net-libs/libnids-1.18
- >=dev-libs/openssl-0.9.6e"
-# dependencies only for building our own sys-libs/db
-DEPEND="${RDEPEND}
- virtual/libc
- =sys-libs/db-1*
- sys-devel/libtool
- sys-devel/m4"
-
-src_unpack() {
- unpack db-${DB_VER}.tar.gz
- unpack ${P}.tar.gz
-
- # Making sure data files get correctly installed and that dsniff
- # can find them
- # Working around dsniff b0rky config script
- # Data stuff goes into /etc/dsniff
- cd ${S}
- epatch ${FILESDIR}/${PV}-libnet-1.0.patch
- sed -i \
- -e 's:-ldb:-ldb -lpthread:' \
- -e "s:lib':':" \
- configure || die "sed configure"
- sed -i 's:-DDSNIFF_LIBDIR=\\\"$(libdir)/\\\"::' Makefile.in || die "sed makefile"
- sed -i 's:/usr/local/lib:/etc/dsniff:' pathnames.h || die "sed pathnames"
- epatch ${FILESDIR}/${PV}-makefile.patch
-
- # Allow amd64 compilation
- append-ldflags -lresolv
-}
-
-src_compile() {
- cd ${WORKDIR}/db-${DB_VER}/dist
- ./configure \
- --host=${CHOST} \
- --enable-compat185 || die "./configure of db-${DB_VER} failed"
- emake || die "build of db-${DB_VER} failed"
-
- # Another workaround around the crappy config script
- cd ${S}
- econf --with-db=../db-${DB_VER} || die
- make || die
-}
-
-src_install() {
- make install install_prefix=${D} || die
- dodir /etc/dsniff
- mv ${D}/usr/{dnsspoof.hosts,dsniff.{magic,services}} ${D}/etc/dsniff/
- dodoc CHANGES README TODO
-}
diff --git a/net-analyzer/dsniff/dsniff-2.3-r6.ebuild b/net-analyzer/dsniff/dsniff-2.3-r6.ebuild
deleted file mode 100644
index b0d4059a6d03..000000000000
--- a/net-analyzer/dsniff/dsniff-2.3-r6.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3-r6.ebuild,v 1.1 2005/09/09 03:24:38 vanquirius Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A collection of tools for network auditing and penetration testing"
-HOMEPAGE="http://monkey.org/~dugsong/${PN}/"
-SRC_URI="${HOMEPAGE}/${P}.tar.gz"
-LICENSE="DSNIFF"
-SLOT="0"
-KEYWORDS="~amd64 ~alpha ~ppc ~x86"
-IUSE=""
-
-RDEPEND="virtual/libpcap
- <net-libs/libnet-1.1
- >=net-libs/libnet-1.0.2a-r3
- >=net-libs/libnids-1.18
- >=dev-libs/openssl-0.9.6e
- ~sys-libs/db-3.2.9"
-
-src_unpack() {
- unpack ${A}
-
- # Making sure data files get correctly installed and that dsniff
- # can find them
- # Working around dsniff b0rky config script
- # Data stuff goes into /etc/dsniff
- cd ${S}
- epatch ${FILESDIR}/${PV}-libnet-1.0.patch
- sed -i \
- -e 's:-ldb:-ldb -lpthread:' \
- -e "s:lib':':" \
- configure || die "sed configure"
- sed -i 's:-DDSNIFF_LIBDIR=\\\"$(libdir)/\\\"::' Makefile.in || die "sed makefile"
- sed -i 's:/usr/local/lib:/etc/dsniff:' pathnames.h || die "sed pathnames"
- epatch ${FILESDIR}/${PV}-makefile.patch
-
- # Allow amd64 compilation
- append-ldflags -lresolv
-}
-
-src_install() {
- make install install_prefix=${D} || die
- dodir /etc/dsniff
- mv ${D}/usr/{dnsspoof.hosts,dsniff.{magic,services}} ${D}/etc/dsniff/
- dodoc CHANGES README TODO
-}
diff --git a/net-analyzer/dsniff/dsniff-2.3-r7.ebuild b/net-analyzer/dsniff/dsniff-2.3-r7.ebuild
index e76248b149c3..2ee665cffad7 100644
--- a/net-analyzer/dsniff/dsniff-2.3-r7.ebuild
+++ b/net-analyzer/dsniff/dsniff-2.3-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3-r7.ebuild,v 1.1 2005/10/15 09:34:08 mkay Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3-r7.ebuild,v 1.2 2005/11/27 02:44:14 vanquirius Exp $
inherit eutils flag-o-matic
@@ -9,7 +9,7 @@ HOMEPAGE="http://monkey.org/~dugsong/${PN}/"
SRC_URI="${HOMEPAGE}/${P}.tar.gz"
LICENSE="DSNIFF"
SLOT="0"
-KEYWORDS="~amd64 ~alpha ~ppc ~x86"
+KEYWORDS="~amd64 ~alpha ~ppc x86"
IUSE=""
RDEPEND="virtual/libpcap
@@ -27,15 +27,15 @@ src_unpack() {
# can find them
# Working around dsniff b0rky config script
# Data stuff goes into /etc/dsniff
- cd ${S}
- epatch ${FILESDIR}/${PV}-libnet-1.0.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-libnet-1.0.patch
sed -i \
-e 's:-ldb:-ldb -lpthread:' \
-e "s:lib':':" \
configure || die "sed configure"
sed -i 's:-DDSNIFF_LIBDIR=\\\"$(libdir)/\\\"::' Makefile.in || die "sed makefile"
sed -i 's:/usr/local/lib:/etc/dsniff:' pathnames.h || die "sed pathnames"
- epatch ${FILESDIR}/${PV}-makefile.patch
+ epatch "${FILESDIR}"/${PV}-makefile.patch
# Allow amd64 compilation
append-ldflags -lresolv
@@ -46,8 +46,8 @@ src_unpack() {
}
src_install() {
- make install install_prefix=${D} || die
+ make install install_prefix="${D}" || die
dodir /etc/dsniff
- mv ${D}/usr/{dnsspoof.hosts,dsniff.{magic,services}} ${D}/etc/dsniff/
+ mv "${D}"/usr/{dnsspoof.hosts,dsniff.{magic,services}} "${D}"/etc/dsniff/
dodoc CHANGES README TODO
}
diff --git a/net-analyzer/dsniff/files/digest-dsniff-2.3-r5 b/net-analyzer/dsniff/files/digest-dsniff-2.3-r5
deleted file mode 100644
index e1135460a43f..000000000000
--- a/net-analyzer/dsniff/files/digest-dsniff-2.3-r5
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238
-MD5 183e336a45e38013f3af840bddec44b4 dsniff-2.3.tar.gz 126797
diff --git a/net-analyzer/dsniff/files/digest-dsniff-2.3-r6 b/net-analyzer/dsniff/files/digest-dsniff-2.3-r6
deleted file mode 100644
index 9942098f31ff..000000000000
--- a/net-analyzer/dsniff/files/digest-dsniff-2.3-r6
+++ /dev/null
@@ -1 +0,0 @@
-MD5 183e336a45e38013f3af840bddec44b4 dsniff-2.3.tar.gz 126797