summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ethereal/ethereal-0.9.10.ebuild')
-rw-r--r--net-analyzer/ethereal/ethereal-0.9.10.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/net-analyzer/ethereal/ethereal-0.9.10.ebuild b/net-analyzer/ethereal/ethereal-0.9.10.ebuild
index 02e5c8ca87ad..3fa3c3cc7d60 100644
--- a/net-analyzer/ethereal/ethereal-0.9.10.ebuild
+++ b/net-analyzer/ethereal/ethereal-0.9.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.9.10.ebuild,v 1.4 2003/03/12 20:30:18 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.9.10.ebuild,v 1.5 2003/06/14 21:55:15 aliz Exp $
IUSE="gtk ipv6 snmp ssl gtk2"
@@ -38,18 +38,15 @@ src_unpack() {
src_compile() {
local myconf
- if [ "`use gtk2`" ]
- then
- myconf="--enable-gtk2"
- elif [ -z "`use gtk`" ]
- then
- myconf="--disable-ethereal"
- fi
-
+
+ if [ -z "`use gtk`" ] && [ -z "`use gtk2`" ]; then
+ myconf="${myconf} --disable-ethereal"
+ fi
+
+ use gtk2 && myconf="${myconf} --enable-gtk2"
use ssl || myconf="${myconf} --without-ssl"
use snmp || myconf="${myconf} --without-ucdsnmp"
use ipv6 && myconf="${myconf} --enable-ipv6"
- use gtk || myconf="${myconf} --disable-ethereal"
addwrite "/usr/share/snmp/mibs/"