summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/httping/httping-1.3.1.ebuild')
-rw-r--r--net-analyzer/httping/httping-1.3.1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/net-analyzer/httping/httping-1.3.1.ebuild b/net-analyzer/httping/httping-1.3.1.ebuild
deleted file mode 100644
index 22c91a53c4e2..000000000000
--- a/net-analyzer/httping/httping-1.3.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.3.1.ebuild,v 1.5 2010/01/06 19:57:18 ranger Exp $
-
-EAPI="2"
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="http protocol ping-like program"
-HOMEPAGE="http://www.vanheusden.com/httping/"
-SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 hppa ~mips ~ppc ppc64 ~sparc x86"
-IUSE="debug ssl"
-
-RDEPEND=">=sys-libs/ncurses-5
- ssl? ( dev-libs/openssl )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- sed 's:^CFLAGS=:CFLAGS+=:' -i Makefile || die
-}
-
-src_compile() {
- append-flags -D_GNU_SOURCE
- emake \
- CC="$(tc-getCC)" \
- $(use ssl && echo SSL=yes || echo SSL=no) \
- $(use debug && echo DEBUG=yes || echo DEBUG=no) \
- || die "emake failed"
-}
-
-src_install() {
- dobin httping || die "dobin failed"
- doman httping.1 || die "doman failed"
- dodoc readme.txt || die "dodoc failed"
-}