summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/zabbix/zabbix-1.6.9.ebuild')
-rw-r--r--net-analyzer/zabbix/zabbix-1.6.9.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/net-analyzer/zabbix/zabbix-1.6.9.ebuild b/net-analyzer/zabbix/zabbix-1.6.9.ebuild
index e2cf2570800d..fd0490810de8 100644
--- a/net-analyzer/zabbix/zabbix-1.6.9.ebuild
+++ b/net-analyzer/zabbix/zabbix-1.6.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/zabbix-1.6.9.ebuild,v 1.1 2011/03/04 15:49:56 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/zabbix-1.6.9.ebuild,v 1.2 2011/07/08 10:20:59 ssuominen Exp $
EAPI="2"
@@ -31,14 +31,14 @@ RDEPEND="${RDEPEND}
server? ( net-analyzer/fping )
frontend? ( dev-lang/php )"
-useq frontend && need_php_httpd
+use frontend && need_php_httpd
pkg_setup() {
- if useq server || useq proxy ; then
+ if use server || use proxy ; then
local dbnum dbtypes="mysql oracle postgres sqlite3" dbtype
declare -i dbnum=0
for dbtype in ${dbtypes}; do
- useq ${dbtype} && let dbnum++
+ use ${dbtype} && let dbnum++
done
if [ ${dbnum} -gt 1 ]; then
eerror
@@ -52,7 +52,7 @@ pkg_setup() {
eerror
die "No database type selected."
fi
- if useq oracle; then
+ if use oracle; then
if [ -z "${ORACLE_HOME}" ]; then
eerror
eerror "The environment variable ORACLE_HOME must be set"
@@ -70,7 +70,7 @@ pkg_setup() {
fi
fi
- if useq frontend; then
+ if use frontend; then
webapp_pkg_setup
require_gd
fi
@@ -80,7 +80,7 @@ pkg_setup() {
}
pkg_postinst() {
- if useq server || useq proxy ; then
+ if use server || use proxy ; then
elog
elog "You need to configure your database for Zabbix."
elog
@@ -109,7 +109,7 @@ pkg_postinst() {
fi
fi
- if useq server; then
+ if use server; then
elog
elog "For distributed monitoring you have to run:"
elog
@@ -151,7 +151,7 @@ pkg_postinst() {
chmod 0640 \
"${ROOT}"/etc/zabbix/zabbix_*
- if useq server || useq proxy ; then
+ if use server || use proxy ; then
# check for fping
fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
case "${fping_perms}" in
@@ -209,7 +209,7 @@ src_install() {
/var/log/zabbix \
/var/run/zabbix
- if useq server; then
+ if use server; then
insinto /etc/zabbix
doins \
"${FILESDIR}/1.6.6"/zabbix_server.conf \
@@ -232,7 +232,7 @@ src_install() {
/etc/zabbix/zabbix_trapper.conf
fi
- if useq proxy; then
+ if use proxy; then
doinitd \
"${FILESDIR}/1.6.6"/init.d/zabbix-proxy
dosbin \
@@ -248,7 +248,7 @@ src_install() {
create
fi
- if useq agent; then
+ if use agent; then
insinto /etc/zabbix
doins \
"${FILESDIR}/1.6.6"/zabbix_agent.conf \
@@ -286,7 +286,7 @@ src_install() {
dodoc README INSTALL NEWS ChangeLog
- if useq frontend; then
+ if use frontend; then
webapp_src_preinst
cp -R frontends/php/* "${D}/${MY_HTDOCSDIR}"
webapp_postinst_txt en "${FILESDIR}/"1.6.6/postinstall-en.txt