summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/ppp/ppp-2.4.2-r15.ebuild')
-rw-r--r--net-dialup/ppp/ppp-2.4.2-r15.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/net-dialup/ppp/ppp-2.4.2-r15.ebuild b/net-dialup/ppp/ppp-2.4.2-r15.ebuild
index 9d5d113dc7c6..9d8eff57bb8f 100644
--- a/net-dialup/ppp/ppp-2.4.2-r15.ebuild
+++ b/net-dialup/ppp/ppp-2.4.2-r15.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.2-r15.ebuild,v 1.11 2005/11/14 14:38:49 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.2-r15.ebuild,v 1.12 2006/01/24 18:09:32 mrness Exp $
inherit eutils gnuconfig flag-o-matic linux-info
@@ -8,13 +8,14 @@ DESCRIPTION="Point-to-point protocol (PPP)"
HOMEPAGE="http://www.samba.org/ppp"
SRC_URI="ftp://ftp.samba.org/pub/ppp/${P}.tar.gz
mirror://gentoo/${P}-patches-20050729.tar.gz
- mppe-mppc? ( http://www.polbox.com/h/hs001/ppp-2.4.2-mppe-mppc-1.1.patch.gz )
+ mppe-mppc? ( http://mppe-mppc.alphacron.de/ppp-2.4.2-mppe-mppc-1.1.patch.gz )
dhcp? ( http://www.netservers.co.uk/gpl/ppp-dhcpc.tgz )"
LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
IUSE="activefilter atm dhcp ipv6 mppe-mppc pam radius"
+RESTRICT="nomirror"
RDEPEND="virtual/libc
activefilter? ( >=virtual/libpcap-0.9.3 )
@@ -24,10 +25,15 @@ DEPEND="${RDEPEND}
>=sys-apps/sed-4"
pkg_setup() {
- if ! use radius; then
+ if use mppe-mppc; then
echo
- ewarn "RADIUS plugins installation is now controled by radius useflag!"
- ewarn "If you need them, hit Ctrl-C now!"
+ ewarn "The mppe-mppc flag overwrites the pppd native MPPE support with MPPE-MPPC"
+ ewarn "patch developed by Jan Dubiec."
+ ewarn "The resulted pppd will work only with patched kernels with version <= 2.6.14."
+ einfo "You could obtain the kernel patch from MPPE-MPPC homepage:"
+ einfo " http://mppe-mppc.alphacron.de/"
+ ewarn "CAUTION: MPPC is a U.S. patented algorithm!"
+ ewarn "Ask yourself if you really need it and, if you do, consult your lawyer first."
ebeep
fi
}
@@ -179,7 +185,7 @@ src_install() {
insopts -m0644
newins ${FILESDIR}/modules.ppp ppp
if use mppe-mppc; then
- echo 'alias ppp-compress-18 ppp_mppe_mppc' >> ${D}/etc/modules.d/ppp
+ sed -i -e 's/ppp_mppe/ppp_mppe_mppc/' ${D}/etc/modules.d/ppp
fi
dodoc PLUGINS README* SETUP Changes-2.3 FAQ