summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/shorewall/shorewall-1.4.4a.ebuild')
-rw-r--r--net-firewall/shorewall/shorewall-1.4.4a.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-firewall/shorewall/shorewall-1.4.4a.ebuild b/net-firewall/shorewall/shorewall-1.4.4a.ebuild
new file mode 100644
index 000000000000..40c6bcefb275
--- /dev/null
+++ b/net-firewall/shorewall/shorewall-1.4.4a.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /home/cvsroot/gentoo-x86/net-misc/shorewall/shorewall-1.4.1a.ebuild
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Full state iptables firewall"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+HOMEPAGE="http://www.shorewall.net"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/glibc
+ net-firewall/iptables
+ sys-apps/iproute"
+
+RDEPENR=${DEPEND}
+
+src_install () {
+ dodir /var/state
+ PREFIX=${D} ./install.sh /etc/init.d || die
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/shorewall shorewall
+}
+pkg_postinst() {
+ einfo "Read the documentatition from http://www.shorewall.net"
+ einfo "and edit the files in /etc/shorewall before starting the firewall"
+}