summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild')
-rw-r--r--net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild b/net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild
index e9daa5434126..083c0468cf96 100644
--- a/net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild
+++ b/net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild,v 1.1 2013/10/29 20:06:31 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild,v 1.2 2013/10/30 21:41:03 johu Exp $
EAPI=5
@@ -21,12 +21,26 @@ fi
LICENSE="LGPL-2.1"
SLOT="4"
-IUSE="debug"
+IUSE="debug modemmanager"
DEPEND="
>=net-im/ktp-common-internals-${PV}
net-im/telepathy-mission-control
net-libs/telepathy-glib
>=net-libs/telepathy-qt-0.9.3
+ modemmanager? ( net-libs/libmm-qt )
"
RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-libmm-qt-api.patch"
+ "${FILESDIR}/${P}-libmm-qt-optional.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build modemmanager pintxo)
+ )
+
+ kde4-base_src_configure
+}