summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libnet/libnet-1.1.4.ebuild')
-rw-r--r--net-libs/libnet/libnet-1.1.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/libnet/libnet-1.1.4.ebuild b/net-libs/libnet/libnet-1.1.4.ebuild
new file mode 100644
index 000000000000..5e763285fc23
--- /dev/null
+++ b/net-libs/libnet/libnet-1.1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.1.4.ebuild,v 1.1 2009/10/20 11:50:04 jer Exp $
+
+DESCRIPTION="library to provide an API for commonly used low-level network functions (mainly packet injection)"
+HOMEPAGE="http://libnet-dev.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/libnet-dev/libnet-dev/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND="sys-devel/autoconf"
+RDEPEND=""
+
+src_install(){
+ emake DESTDIR="${D}" install || die "Failed to install"
+
+ dodoc README \
+ doc/{BUGS,CHANGELOG,CONTRIB,DESIGN_NOTES,MIGRATION} \
+ doc/{PACKET_BUILDING,PORTED,RAWSOCKET_NON_SEQUITUR,TODO}
+ if use doc ; then
+ dohtml -r doc/html/*
+ docinto sample
+ dodoc sample/*.[ch]
+ fi
+}