summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/getmail/getmail-4.22.2.ebuild')
-rw-r--r--net-mail/getmail/getmail-4.22.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-mail/getmail/getmail-4.22.2.ebuild b/net-mail/getmail/getmail-4.22.2.ebuild
new file mode 100644
index 000000000000..5f4fc64ff673
--- /dev/null
+++ b/net-mail/getmail/getmail-4.22.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.22.2.ebuild,v 1.1 2011/11/13 19:03:30 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_MODNAME="getmailcore"
+
+inherit distutils
+
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~ppc-macos ~x86-macos ~x64-solaris"
+IUSE=""
+
+src_prepare() {
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+ distutils_src_prepare
+}