summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/freerdp/freerdp-1.1.0_pre20121004.ebuild')
-rw-r--r--net-misc/freerdp/freerdp-1.1.0_pre20121004.ebuild94
1 files changed, 0 insertions, 94 deletions
diff --git a/net-misc/freerdp/freerdp-1.1.0_pre20121004.ebuild b/net-misc/freerdp/freerdp-1.1.0_pre20121004.ebuild
deleted file mode 100644
index 5f0c1d894e66..000000000000
--- a/net-misc/freerdp/freerdp-1.1.0_pre20121004.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/freerdp/freerdp-1.1.0_pre20121004.ebuild,v 1.1 2012/10/07 00:31:10 floppym Exp $
-
-EAPI="4"
-
-inherit cmake-utils
-
-if [[ ${PV} != 9999* ]]; then
- SRC_URI="mirror://github/FreeRDP/FreeRDP/${P}.tar.gz
- mirror://gentoo/${P}.tar.gz
- http://dev.gentoo.org/~floppym/distfiles/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-else
- inherit git-2
- SRC_URI=""
- EGIT_REPO_URI="git://github.com/FreeRDP/FreeRDP.git
- https://github.com/FreeRDP/FreeRDP.git"
- KEYWORDS=""
-fi
-
-DESCRIPTION="Free implementation of the Remote Desktop Protocol"
-HOMEPAGE="http://www.freerdp.com/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="alsa +channels +client cups debug directfb doc ffmpeg gstreamer jpeg
- pulseaudio smartcard sse2 test X xinerama xv"
-
-RESTRICT="test"
-
-RDEPEND="
- dev-libs/openssl
- sys-libs/zlib
- alsa? ( media-libs/alsa-lib )
- cups? ( net-print/cups )
- client? (
- directfb? ( dev-libs/DirectFB )
- X? (
- x11-libs/libXcursor
- x11-libs/libXext
- xinerama? ( x11-libs/libXinerama )
- xv? ( x11-libs/libXv )
- )
- )
- ffmpeg? ( virtual/ffmpeg )
- gstreamer? (
- media-libs/gstreamer
- media-libs/gst-plugins-base
- x11-libs/libXrandr
- )
- jpeg? ( virtual/jpeg )
- pulseaudio? ( media-sound/pulseaudio )
- smartcard? ( sys-apps/pcsc-lite )
- X? (
- x11-libs/libX11
- x11-libs/libxkbfile
- )
-"
-DEPEND="${RDEPEND}
- client? ( X? ( doc? (
- app-text/docbook-xml-dtd:4.1.2
- app-text/xmlto
- ) ) )
- test? ( dev-util/cunit )
-"
-
-DOCS=( README )
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_with alsa ALSA)
- $(cmake-utils_use_with channels CHANNELS)
- $(cmake-utils_use_with client CLIENT)
- $(cmake-utils_use_with cups CUPS)
- $(cmake-utils_use_with debug DEBUG_ALL)
- $(cmake-utils_use_with doc MANPAGES)
- $(cmake-utils_use_with directfb DIRECTFB)
- $(cmake-utils_use_with ffmpeg FFMPEG)
- $(cmake-utils_use_with gstreamer GSTREAMER)
- $(cmake-utils_use_with jpeg JPEG)
- $(cmake-utils_use_with pulseaudio PULSEAUDIO)
- $(cmake-utils_use_with smartcard PCSC)
- $(cmake-utils_use_with sse2 SSE2)
- $(cmake-utils_use_with test CUNIT)
- $(cmake-utils_use_with X X11)
- $(cmake-utils_use_with X XCURSOR)
- $(cmake-utils_use_with X XEXT)
- $(cmake-utils_use_with X XKBFILE)
- $(cmake-utils_use_with xinerama XINERAMA)
- $(cmake-utils_use_with xv XV)
- )
- cmake-utils_src_configure
-}