summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rsync/rsync-2.6.1.ebuild')
-rw-r--r--net-misc/rsync/rsync-2.6.1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/rsync/rsync-2.6.1.ebuild b/net-misc/rsync/rsync-2.6.1.ebuild
new file mode 100644
index 000000000000..d5817ede0916
--- /dev/null
+++ b/net-misc/rsync/rsync-2.6.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.6.1.ebuild,v 1.1 2004/06/23 01:16:46 vapier Exp $
+
+inherit eutils flag-o-matic gcc
+
+DESCRIPTION="File transfer program to keep remote files into sync"
+HOMEPAGE="http://rsync.samba.org/"
+SRC_URI="http://rsync.samba.org/ftp/rsync/old-versions/${P}.tar.gz
+ acl? ( http://www.saout.de/misc/rsync-2.6.2-acl.diff.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha arm ~hppa ~amd64 ~ia64 ~ppc64 s390"
+IUSE="build static acl"
+
+RDEPEND="virtual/glibc
+ !build? ( >=dev-libs/popt-1.5 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ acl? ( sys-apps/acl )"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ cd ${S}
+ use acl && epatch ${DISTDIR}/rsync-2.6.2-acl.diff.bz2
+
+ # yes, updating the man page is very important.
+ sed -i \
+ -e 's|/etc/rsyncd|/etc/rsync/rsyncd|g' \
+ rsyncd.conf.5 \
+ || die "sed rsyncd.conf.5 failed"
+}
+
+src_compile() {
+ [ "`gcc-version`" == "2.95" ] && append-ldflags -lpthread
+ use static && append-ldflags -static
+
+ econf \
+ $(use_with build included-popt) \
+ $(use_with acl acl-support) \
+ $(use_enable ipv6) \
+ --with-rsyncd-conf=/etc/rsync/rsyncd.conf \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ insinto /etc/conf.d && newins "${FILESDIR}/rsyncd.conf.d" rsyncd
+ exeinto /etc/init.d && newexe "${FILESDIR}/rsyncd.init.d" rsyncd
+ if ! use build ; then
+ dodir /etc/rsync
+ dodoc NEWS OLDNEWS README TODO tech_report.tex
+ if [ ! -e ${ROOT}/etc/rsync/rsyncd.conf ] ; then
+ insinto /etc/rsync
+ doins "${FILESDIR}/rsyncd.conf"
+ fi
+ else
+ rm -rf "${D}/usr/share"
+ fi
+}
+
+pkg_postinst() {
+ ewarn "Please make sure you do NOT disable the rsync server running"
+ ewarn "in a chroot. Please check /etc/rsync/rsyncd.conf and make sure"
+ ewarn "it says: use chroot = yes"
+}