summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds/portmap/portmap-5b-r6.ebuild')
-rw-r--r--net-nds/portmap/portmap-5b-r6.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/net-nds/portmap/portmap-5b-r6.ebuild b/net-nds/portmap/portmap-5b-r6.ebuild
index c0356ac72dd9..9076326dec7b 100644
--- a/net-nds/portmap/portmap-5b-r6.ebuild
+++ b/net-nds/portmap/portmap-5b-r6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/portmap/portmap-5b-r6.ebuild,v 1.11 2002/12/15 10:44:21 bjb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/portmap/portmap-5b-r6.ebuild,v 1.12 2003/02/10 07:38:13 seemant Exp $
+
+inherit eutils
MY_P=${PN}_${PV}eta
A0=portmap_5beta.dif
@@ -9,19 +11,18 @@ DESCRIPTION="Netkit - portmapper"
SRC_URI="ftp://ftp.porcupine.org/pub/security/${MY_P}.tar.gz"
HOMEPAGE="ftp://ftp.porcupine.org/pub/security/index.html"
-DEPEND="virtual/glibc
- sys-apps/tcp-wrappers"
-
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 ppc sparc alpha"
+DEPEND="sys-apps/tcp-wrappers"
+
src_unpack() {
unpack ${A}
cd $S || die
- patch -p0 < $FILESDIR/$A0 || die
+ epatch $FILESDIR/$A0
mv Makefile Makefile.orig || die
- sed -e "s/-O2/$CFLAGS/" Makefile.orig > Makefile || die
+ sed -e "s:-O2:$CFLAGS:" Makefile.orig > Makefile || die
}
src_compile() {