summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/nget/nget-0.22.1.ebuild')
-rw-r--r--net-news/nget/nget-0.22.1.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/net-news/nget/nget-0.22.1.ebuild b/net-news/nget/nget-0.22.1.ebuild
index 181e5b749c0b..c687c71ad0db 100644
--- a/net-news/nget/nget-0.22.1.ebuild
+++ b/net-news/nget/nget-0.22.1.ebuild
@@ -1,26 +1,27 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/nget/nget-0.22.1.ebuild,v 1.4 2003/07/25 21:21:18 taviso Exp $
-
-IUSE="static build"
+# $Header: /var/cvsroot/gentoo-x86/net-news/nget/nget-0.22.1.ebuild,v 1.5 2003/08/03 04:21:36 vapier Exp $
NPVER=20011209
-S=${WORKDIR}/${P}
DESCRIPTION="Network utility to retrieve files from an NNTP news server"
-SRC_URI="http://telia.dl.sourceforge.net/sourceforge/nget/${P}+uulib.tar.gz"
HOMEPAGE="http://nget.sourceforge.net/"
-RDEPEND="virtual/glibc"
-DEPEND="$RDEPEND dev-libs/popt"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/nget/${P}+uulib.tar.gz"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
+IUSE="static debug"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ dev-libs/popt"
src_compile() {
local myconf
# use nls || myconf="--disable-nls"
# use ssl && myconf="${myconf} --with-ssl"
# use ssl || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
-# [ -z "$DEBUG" ] && myconf="${myconf} --disable-debug"
+# use debug && myconf="${myconf} --disable-debug"
# use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
./configure --prefix=/usr \
--infodir=/usr/share/info --mandir=/usr/share/man $myconf || die
@@ -31,12 +32,12 @@ src_compile() {
fi
}
-src_install() {
+src_install() {
if use build; then
insinto /usr
dobin ${S}/src/nget
return
- fi
+ fi
make prefix=${D}/usr \
mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
dodoc COPYING ChangeLog FAQ README TODO .ngetrc