summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/yaggui')
-rw-r--r--net-p2p/yaggui/ChangeLog10
-rw-r--r--net-p2p/yaggui/Manifest5
-rw-r--r--net-p2p/yaggui/files/digest-yaggui-0.91
-rw-r--r--net-p2p/yaggui/files/yaggui.sh19
-rw-r--r--net-p2p/yaggui/metadata.xml5
-rw-r--r--net-p2p/yaggui/yaggui-0.9.ebuild28
6 files changed, 68 insertions, 0 deletions
diff --git a/net-p2p/yaggui/ChangeLog b/net-p2p/yaggui/ChangeLog
new file mode 100644
index 000000000000..01d2bc54ab9c
--- /dev/null
+++ b/net-p2p/yaggui/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-p2p/yaggui
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/yaggui/ChangeLog,v 1.1 2004/08/30 20:16:52 squinky86 Exp $
+
+*yaggui-0.9 (30 Aug 2004)
+
+ 30 Aug 2004; Jon Hood <squinky86@gentoo.org> +metadata.xml,
+ +files/yaggui.sh, +yaggui-0.9.ebuild:
+ Initial import.
+
diff --git a/net-p2p/yaggui/Manifest b/net-p2p/yaggui/Manifest
new file mode 100644
index 000000000000..97cde9e58213
--- /dev/null
+++ b/net-p2p/yaggui/Manifest
@@ -0,0 +1,5 @@
+MD5 c5b7a0cfb1a909b80bf623404909e183 yaggui-0.9.ebuild 677
+MD5 f7956d7d2ccc0b75f7ef104bae823e55 ChangeLog 352
+MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
+MD5 7ca300103ab322a01edbc65bd9dc46da files/digest-yaggui-0.9 63
+MD5 44d8be3f2e56dd37d0a56809cada80ed files/yaggui.sh 610
diff --git a/net-p2p/yaggui/files/digest-yaggui-0.9 b/net-p2p/yaggui/files/digest-yaggui-0.9
new file mode 100644
index 000000000000..1a13adf4d5b1
--- /dev/null
+++ b/net-p2p/yaggui/files/digest-yaggui-0.9
@@ -0,0 +1 @@
+MD5 84132a78a0980527e254970e91ad6552 Yaggui-0.9-src.zip 297620
diff --git a/net-p2p/yaggui/files/yaggui.sh b/net-p2p/yaggui/files/yaggui.sh
new file mode 100644
index 000000000000..13f3bbb05515
--- /dev/null
+++ b/net-p2p/yaggui/files/yaggui.sh
@@ -0,0 +1,19 @@
+#!/bin/bash
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/yaggui/files/yaggui.sh,v 1.1 2004/08/30 20:16:52 squinky86 Exp $
+
+if [ ! "$(ps -A | grep -e giftd)" ]
+then
+ echo "Error! Unable to find giFT daemon!"
+ echo "Attempting to start the giFT daemon..."
+ giftd > /dev/null &
+ if [ ! "$(ps -A | grep -e giftd)" ]
+ then
+ echo "Could not start the giFT daemon! Continuing to load Yaggui..."
+ else
+ echo "giFT daemon started, continuing to load Yaggui..."
+ fi
+fi
+
+java -jar /usr/share/yaggui/lib/Yaggui.jar
diff --git a/net-p2p/yaggui/metadata.xml b/net-p2p/yaggui/metadata.xml
new file mode 100644
index 000000000000..aa0f3664825f
--- /dev/null
+++ b/net-p2p/yaggui/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-p2p</herd>
+</pkgmetadata>
diff --git a/net-p2p/yaggui/yaggui-0.9.ebuild b/net-p2p/yaggui/yaggui-0.9.ebuild
new file mode 100644
index 000000000000..082118d17629
--- /dev/null
+++ b/net-p2p/yaggui/yaggui-0.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/yaggui/yaggui-0.9.ebuild,v 1.1 2004/08/30 20:16:52 squinky86 Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Yet Another Gift GUI in java"
+HOMEPAGE="http://yaggui.sourceforge.net/"
+SRC_URI="mirror://sourceforge/yaggui/${P/y/Y}-src.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-java/ant-1.4"
+RDEPEND=">=virtual/jdk-1.4
+ virtual/x11"
+S=${WORKDIR}/${P}-src
+
+src_compile() {
+ ant build-jar || die
+}
+
+src_install() {
+ java-pkg_dojar build/Yaggui.jar
+ dohtml docs/*
+ exeinto /usr/bin
+ newexe ${FILESDIR}/${PN}.sh ${PN}
+}