summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-voip/telepathy-gabble/telepathy-gabble-0.5.3.ebuild')
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.5.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.5.3.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.5.3.ebuild
new file mode 100644
index 000000000000..5e6af624f705
--- /dev/null
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.5.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/telepathy-gabble-0.5.3.ebuild,v 1.1 2007/02/11 11:09:24 peper Exp $
+
+DESCRIPTION="A Jabber/XMPP connection manager, this handles single and multi user chats and voice calls."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=dev-libs/glib-2.4
+ || ( >=dev-libs/dbus-glib-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.61 ) )
+ >=net-libs/loudmouth-1.1.1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable debug backtrace) \
+ $(use_enable debug handle-leak-debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ vecho ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ if ! dbus-launch emake -j1 check; then
+ hasq test $FEATURES && die "Make check failed. See above for details."
+ hasq test $FEATURES || eerror "Make check failed. See above for details."
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog
+}