summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/octave/octave-3.4.3-r1.ebuild')
-rw-r--r--sci-mathematics/octave/octave-3.4.3-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sci-mathematics/octave/octave-3.4.3-r1.ebuild b/sci-mathematics/octave/octave-3.4.3-r1.ebuild
index 906d5112fad0..b8a32da12d34 100644
--- a/sci-mathematics/octave/octave-3.4.3-r1.ebuild
+++ b/sci-mathematics/octave/octave-3.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.4.3-r1.ebuild,v 1.3 2012/01/19 15:06:57 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.4.3-r1.ebuild,v 1.4 2012/01/21 18:28:10 bicatali Exp $
EAPI=4
inherit eutils base autotools toolchain-funcs
@@ -49,7 +49,7 @@ DEPEND="${RDEPEND}
dev-util/gperf
dev-util/pkgconfig"
-pkg_pretend() {
+pkg_setup() {
use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp && \
die "You have openmp enabled but your current gcc does not support it"
}