summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/grep')
-rw-r--r--sys-apps/grep/ChangeLog6
-rw-r--r--sys-apps/grep/Manifest12
-rw-r--r--sys-apps/grep/grep-2.5.1-r6.ebuild10
-rw-r--r--sys-apps/grep/grep-2.5.1-r7.ebuild6
4 files changed, 25 insertions, 9 deletions
diff --git a/sys-apps/grep/ChangeLog b/sys-apps/grep/ChangeLog
index 419ac1389d0f..fc34f7c1d136 100644
--- a/sys-apps/grep/ChangeLog
+++ b/sys-apps/grep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/grep
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.44 2005/03/22 08:06:30 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.45 2005/05/30 02:41:07 solar Exp $
+
+ 29 May 2005; <solar@gentoo.org> grep-2.5.1-r6.ebuild, grep-2.5.1-r7.ebuild:
+ - update sys-apps/grep to use libc expanded variable elibc_uclibc vs uclibc so
+ USE=-* works
22 Mar 2005; Jeremy Huddleston <eradicator@gentoo.org>
grep-2.5.1-r6.ebuild, grep-2.5.1-r7.ebuild:
diff --git a/sys-apps/grep/Manifest b/sys-apps/grep/Manifest
index 1810793fecaf..f6617d6df2a8 100644
--- a/sys-apps/grep/Manifest
+++ b/sys-apps/grep/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 5c1510e20a43c023fa1329fb8ef59efc grep-2.5.1-r7.ebuild 1990
MD5 97b1eaf5feac1593d7085913ce9b5deb grep-2.5.1-r6.ebuild 2240
MD5 48f72d4099f9ed7d3a69a48eaf04b267 ChangeLog 7109
@@ -13,3 +16,12 @@ MD5 c723a8ca50e51326608931018be4f06b files/grep-2.5.1-restrict_arr.patch 501
MD5 792f6cb13959979de2b10537067603bb files/2.5.1-manpage-line-buffering.patch 477
MD5 e39e9fd198a2c0a5984f2c7d188b3c49 files/2.5.1-utf8-case.patch 933
MD5 16d6cd54c93041d4f4bef59a9e327d04 files/2.5.1-tests.patch 1786
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iQCVAwUBQpp9Sp4WFLgrx1GWAQJ1+gQAj7aHh07mONg8upCiK87hcHGU4XiCyKtJ
+PXGOYVFGi+u5vix85najKp3cn9w/BrycQiWD9q5GR/qqqF1pcly0FJ6WqgSnKPeF
+8/ydHyv6CFspFpWsKer848Ftn55SxGizSTh1A9546XXlvzeEMz7ro+ej8yMaggYg
+KlllbXCGt94=
+=JE7t
+-----END PGP SIGNATURE-----
diff --git a/sys-apps/grep/grep-2.5.1-r6.ebuild b/sys-apps/grep/grep-2.5.1-r6.ebuild
index e4ada887a143..edd78c36024b 100644
--- a/sys-apps/grep/grep-2.5.1-r6.ebuild
+++ b/sys-apps/grep/grep-2.5.1-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r6.ebuild,v 1.13 2005/03/22 08:06:30 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r6.ebuild,v 1.14 2005/05/30 02:41:07 solar Exp $
inherit gnuconfig flag-o-matic eutils multilib
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~ppc-macos"
-IUSE="build nls pcre static uclibc"
+IUSE="build nls pcre static"
RDEPEND="virtual/libc"
DEPEND="${RDEPEND}
@@ -33,7 +33,7 @@ src_unpack() {
# -taviso (20 Aug 2004)
epatch ${FILESDIR}/${PV}-manpage-line-buffering.patch
- use uclibc && epatch ${FILESDIR}/grep-2.5.1-restrict_arr.patch
+ use elibc_uclibc && epatch ${FILESDIR}/grep-2.5.1-restrict_arr.patch
epatch ${FILESDIR}/${PN}-${PV}-fgrep.patch.bz2
epatch ${FILESDIR}/${PN}-${PV}-i18n.patch.bz2
@@ -54,7 +54,7 @@ src_compile() {
append-ldflags -static
fi
- if use uclibc ; then
+ if use elibc_uclibc ; then
myconf="${myconf} --without-included-regex"
else
myconf="${myconf} $(use_enable pcre perl-regexp)"
@@ -62,7 +62,7 @@ src_compile() {
econf ${myconf} || die "econf failed"
- if use pcre && ! use uclibc ; then
+ if use pcre && ! use elibc_uclibc ; then
sed -i -e "s:-lpcre:/usr/$(get_libdir)/libpcre.a:g" {lib,src}/Makefile \
|| die "sed Makefile failed"
fi
diff --git a/sys-apps/grep/grep-2.5.1-r7.ebuild b/sys-apps/grep/grep-2.5.1-r7.ebuild
index 0de1943271c9..197f0e129174 100644
--- a/sys-apps/grep/grep-2.5.1-r7.ebuild
+++ b/sys-apps/grep/grep-2.5.1-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r7.ebuild,v 1.7 2005/05/24 23:12:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r7.ebuild,v 1.8 2005/05/30 02:41:07 solar Exp $
inherit flag-o-matic eutils
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="build nls pcre static uclibc"
+IUSE="build nls pcre static"
RDEPEND=""
DEPEND="${RDEPEND}
@@ -36,7 +36,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PV}-utf8-case.patch
# uclibc does not suffer from this glibc bug.
- use uclibc || epatch "${FILESDIR}"/${PV}-tests.patch
+ use elibc_uclibc || epatch "${FILESDIR}"/${PV}-tests.patch
}
src_compile() {