summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ifplugd/ifplugd-0.20.ebuild')
-rw-r--r--sys-apps/ifplugd/ifplugd-0.20.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/sys-apps/ifplugd/ifplugd-0.20.ebuild b/sys-apps/ifplugd/ifplugd-0.20.ebuild
new file mode 100644
index 000000000000..d15b435a49fc
--- /dev/null
+++ b/sys-apps/ifplugd/ifplugd-0.20.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ifplugd/ifplugd-0.20.ebuild,v 1.1 2003/11/15 16:47:58 wmertens Exp $
+
+DESCRIPTION="Brings up/down ethernet ports automatically with cable detection"
+HOMEPAGE="http://0pointer.de/lennart/projects/ifplugd/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+DEPEND=">=dev-libs/libdaemon-0.3
+ doc? ( app-doc/doxygen net-www/lynx )"
+
+S=${WORKDIR}/${P}
+
+# Gentoo-provided scripts. Version is for the scripts, not ifplugd.
+INITSCRIPT=${FILESDIR}/gentoo-ifplugd-init-v3
+ACTIONSCRIPT=${FILESDIR}/gentoo-ifplugd.action-v2
+CONFFILE=${FILESDIR}/gentoo-ifplugd-conf-v3
+
+src_unpack() {
+ unpack ${A}
+
+ cp ${INITSCRIPT} ${T}/ifplugd
+ cp ${ACTIONSCRIPT} ${T}/ifplugd.action
+
+ # This moves the default location for the script that handles
+ # calling the distro network scripts to /usr/sbin. The reason
+ # is that the user very probably shouldn't mess with it.
+ cd ${S}
+ sed -i~ 's:SYSCONFDIR"/ifplugd/:"/usr/sbin/:' src/ifplugd.c
+}
+
+src_compile() {
+ local myconf
+
+ # These are not needed for building
+ myconf="--disable-xmltoman --disable-subversion"
+
+ use doc \
+ && myconf="${myconf} --enable-doxygen --enable-lynx" \
+ || myconf="${myconf} --disable-doxygen --disable-lynx"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ # Fix init.d configuration
+ cd ${D}/etc
+ rm -rf ifplugd/
+ rm -f init.d/ifplugd
+
+ use doc && dohtml doc/*.html doc/*.css
+
+ dodir /etc/conf.d
+ cp ${CONFFILE} conf.d/ifplugd
+
+ dosbin ${T}/ifplugd.action
+
+ exeinto /etc/init.d
+ doexe ${T}/ifplugd
+}