summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/inputd/inputd-0.1.1.ebuild')
-rw-r--r--sys-apps/inputd/inputd-0.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/inputd/inputd-0.1.1.ebuild b/sys-apps/inputd/inputd-0.1.1.ebuild
new file mode 100644
index 000000000000..93492c4222cf
--- /dev/null
+++ b/sys-apps/inputd/inputd-0.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/inputd/inputd-0.1.1.ebuild,v 1.1 2007/10/17 21:09:35 hansmi Exp $
+
+inherit eutils
+
+DESCRIPTION="inputd is a user-space daemon to emulate key presses trough other
+key combinations"
+HOMEPAGE="http://hansmi.ch/software/inputd"
+SRC_URI="http://hansmi.ch/download/inputd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86 ~ppc64"
+IUSE=""
+
+DEPEND=">=dev-libs/glib-2.10
+ >=sys-kernel/linux-headers-2.6.16"
+RDEPEND="sys-fs/udev"
+
+src_install() {
+ emake DESTDIR=${D} install || die 'installation failed.'
+
+ newinitd ${FILESDIR}/inputd.init inputd
+ dodoc README NEWS doc/FAQ
+
+ insinto /etc
+ doins doc/inputd.conf
+}
+
+pkg_postinst() {
+ ewarn "The configuration syntax has slightly changed between "
+ ewarn "inputd 0.0.x and 0.1.x. Please make sure every statement "
+ ewarn "ends with a semicolon (;)."
+}