summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/smartmontools/smartmontools-5.29.ebuild')
-rw-r--r--sys-apps/smartmontools/smartmontools-5.29.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/smartmontools/smartmontools-5.29.ebuild b/sys-apps/smartmontools/smartmontools-5.29.ebuild
new file mode 100644
index 000000000000..905d55c21dcd
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-5.29.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.29.ebuild,v 1.1 2004/02/24 20:33:53 mholzer Exp $
+
+DESCRIPTION="control and monitor storage systems using the Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.)"
+HOMEPAGE="http://smartmontools.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ econf || die
+ emake ||die
+}
+
+src_install() {
+ dosbin smart{ctl,d}
+ doman *.8 *.5
+ dodoc AUTHORS CHANGELOG COPYING INSTALL NEWS README TODO WARNINGS
+ dodoc smartd.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/smartd.rc smartd
+}
+
+pkg_postinst() {
+ einfo "You can find an example smartd.conf file in"
+ einfo "/usr/share/doc/${PF}/smartd.conf.gz"
+ einfo "Just place it in /etc/ as smartd.conf"
+}