summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/sysvinit')
-rw-r--r--sys-apps/sysvinit/Manifest4
-rw-r--r--sys-apps/sysvinit/files/sysvinit-2.86-docs.patch73
-rw-r--r--sys-apps/sysvinit/files/sysvinit-2.86-shutdown-usage.patch10
-rw-r--r--sys-apps/sysvinit/sysvinit-2.86.ebuild7
4 files changed, 91 insertions, 3 deletions
diff --git a/sys-apps/sysvinit/Manifest b/sys-apps/sysvinit/Manifest
index 25e149f27309..533e4d36e7c2 100644
--- a/sys-apps/sysvinit/Manifest
+++ b/sys-apps/sysvinit/Manifest
@@ -1,10 +1,12 @@
MD5 6b1bc452ca2afd8645f8ecb90b2a1b0d ChangeLog 2488
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 2828b141993d0cc787a38cfb13cb26a6 sysvinit-2.86.ebuild 1973
+MD5 ee7b16bfc9486b08c713f70e8447f1b7 sysvinit-2.86.ebuild 2063
MD5 4bb35af95759582d45324cdf3bc237b7 sysvinit-2.85-r1.ebuild 2545
MD5 64af9a15df244a29ebd5d09307f21a9b files/digest-sysvinit-2.86 64
MD5 5f94105e0b503a39fda5fb65d885e16c files/2.86-gentoo.patch 641
MD5 3ba9251f1f4f0ae0dd30d682b28183dd files/2.86-selinux.patch 6525
MD5 eb3296226618c9805517b4fca35c242e files/inittab 1672
+MD5 b956965acd5408afa0a3937001b2d55e files/sysvinit-2.86-docs.patch 1899
MD5 3c171d9c843284ce606663e4e6da26e9 files/sysvinit-2.85-selinux.patch 6448
MD5 38c0059ecfaa1b09e59a75cc2780aa94 files/digest-sysvinit-2.85-r1 64
+MD5 180a4654bbd070b1264a440c753e6cc0 files/sysvinit-2.86-shutdown-usage.patch 235
diff --git a/sys-apps/sysvinit/files/sysvinit-2.86-docs.patch b/sys-apps/sysvinit/files/sysvinit-2.86-docs.patch
new file mode 100644
index 000000000000..1ee20d9c7a9d
--- /dev/null
+++ b/sys-apps/sysvinit/files/sysvinit-2.86-docs.patch
@@ -0,0 +1,73 @@
+Sync both the content and style of `shutdown -h` and `man shutdown`.
+
+http://bugs.gentoo.org/91724
+
+--- man/shutdown.8
++++ man/shutdown.8
+@@ -11,7 +11,7 @@
+ .B /sbin/shutdown
++.RB [ \-akrhPHfFnc ]
+ .RB [ \-t
+ .IR sec ]
+-.RB [ \-arkhncfFHP ]
+ .I time
+-.RI [ warning-message ]
++.RI [ "warning message" ]
+ .\"}}}
+@@ -41,7 +41,2 @@
+ .\"}}}
+-.\"{{{ -t sec
+-.IP "\fB\-t\fP \fIsec\fP"
+-Tell \fBinit\fP(8) to wait \fIsec\fP seconds between sending processes the
+-warning and the kill signal, before changing to another runlevel.
+-.\"}}}
+ .\"{{{ -k
+@@ -58,7 +53,2 @@
+ .\"}}}
+-.\"{{{ -H
+-.IP \fB\-H\fP
+-Halt action is to halt or drop into boot monitor on systems that
+-support it.
+-.\"}}}
+ .\"{{{ -P
+@@ -67,7 +57,6 @@
+ .\"}}}
+-.\"{{{ -n
+-.IP \fB\-n\fP
+-[DEPRECATED] Don't call \fBinit\fP(8) to do the shutdown but do it ourself.
+-The use of this option is discouraged, and its results are not always what
+-you'd expect.
++.\"{{{ -H
++.IP \fB\-H\fP
++Halt action is to halt or drop into boot monitor on systems that
++support it.
+ .\"}}}
+@@ -81,2 +70,8 @@
+ .\"}}}
++.\"{{{ -n
++.IP \fB\-n\fP
++[DEPRECATED] Don't call \fBinit\fP(8) to do the shutdown but do it ourself.
++The use of this option is discouraged, and its results are not always what
++you'd expect.
++.\"}}}
+ .\"{{{ -c
+@@ -87,2 +82,7 @@
+ .\"}}}
++.\"{{{ -t sec
++.IP "\fB\-t\fP \fIsec\fP"
++Tell \fBinit\fP(8) to wait \fIsec\fP seconds between sending processes the
++warning and the kill signal, before changing to another runlevel.
++.\"}}}
+ .\"{{{ time
+@@ -92,3 +92,3 @@
+ .\"{{{ warning-message
+-.IP \fIwarning-message\fP
++.IP "\fIwarning message\fP"
+ Message to send to all users.
+--- src/shutdown.c
++++ src/shutdown.c
+@@ -104,3 +104,3 @@
+ fprintf(stderr,
+- "Usage:\t shutdown [-akrhHPfnc] [-t secs] time [warning message]\n"
++ "Usage:\t shutdown [-akrhPHfFnc] [-t sec] time [warning message]\n"
+ "\t\t -a: use /etc/shutdown.allow\n"
diff --git a/sys-apps/sysvinit/files/sysvinit-2.86-shutdown-usage.patch b/sys-apps/sysvinit/files/sysvinit-2.86-shutdown-usage.patch
new file mode 100644
index 000000000000..e69abc205fd8
--- /dev/null
+++ b/sys-apps/sysvinit/files/sysvinit-2.86-shutdown-usage.patch
@@ -0,0 +1,10 @@
+Allow non-root users to at least see the help output.
+
+http://bugs.gentoo.org/91724
+
+--- src/shutdown.c
++++ src/shutdown.c
+@@ -462,2 +462,3 @@
+ fprintf(stderr, "shutdown: you must be root to do that!\n");
++ usage();
+ exit(1);
diff --git a/sys-apps/sysvinit/sysvinit-2.86.ebuild b/sys-apps/sysvinit/sysvinit-2.86.ebuild
index 26c564c0f7ec..f45d44e983a7 100644
--- a/sys-apps/sysvinit/sysvinit-2.86.ebuild
+++ b/sys-apps/sysvinit/sysvinit-2.86.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.86.ebuild,v 1.5 2005/02/21 15:31:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.86.ebuild,v 1.6 2005/05/10 02:58:04 vapier Exp $
inherit eutils toolchain-funcs
@@ -20,7 +20,10 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd "${S}"/src
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-docs.patch
+ epatch "${FILESDIR}"/${P}-shutdown-usage.patch
+ cd src
epatch "${FILESDIR}"/${PV}-gentoo.patch
use selinux && epatch "${FILESDIR}"/${PV}-selinux.patch
}