summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/unetbootin/unetbootin-584.ebuild')
-rw-r--r--sys-boot/unetbootin/unetbootin-584.ebuild88
1 files changed, 0 insertions, 88 deletions
diff --git a/sys-boot/unetbootin/unetbootin-584.ebuild b/sys-boot/unetbootin/unetbootin-584.ebuild
deleted file mode 100644
index 8b00cd13a068..000000000000
--- a/sys-boot/unetbootin/unetbootin-584.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-584.ebuild,v 1.2 2013/09/07 14:28:28 jer Exp $
-
-EAPI=5
-
-inherit eutils qt4-r2
-
-DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
-distributions."
-HOMEPAGE="http://unetbootin.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-UNBI_LINGUAS="
- am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
- ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
- zh_CN zh_TW
-"
-
-for lingua in ${UNBI_LINGUAS}; do
- IUSE="${IUSE} linguas_${lingua}"
-done
-
-S="${WORKDIR}"
-
-DEPEND="dev-qt/qtgui:4"
-RDEPEND="${DEPEND}
- sys-fs/mtools
- <sys-boot/syslinux-5
- app-arch/p7zip"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-581-desktop.patch"
-
- # QA check in case linguas are added or removed
- enum() {
- echo ${#}
- }
- [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
- || die "Numbers of recorded and actual linguas do not match"
- unset enum
-
- # Make room between the last line of TRANSLATIONS and the next definition
- sed -i \
- -e '/^DEFINES/s|.*|\n&|g' \
- ${PN}.pro || die
-
- # Remove localisations
- local lingua
- for lingua in ${UNBI_LINGUAS}; do
- if ! use linguas_${lingua}; then
- sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
- rm ${PN}_${lingua}.ts || die
- fi
- done
-}
-
-src_configure() {
- lupdate ${PN}.pro || die
- lrelease ${PN}.pro || die
- eqmake4 ${PN}.pro || die
-}
-
-src_install() {
- dobin ${PN}
-
- domenu ${PN}.desktop
-
- for file in ${PN}*.png; do
- size="${file/${PN}_}"
- size="${size/.png}x${size/.png}"
- insinto /usr/share/icons/hicolor/${size}/apps
- newins ${file} ${PN}.png
- done
-
- local lingua
- for lingua in ${UNBI_LINGUAS}; do
- if use linguas_${lingua}; then
- insinto /usr/share/${PN}
- doins ${PN}_${lingua}.qm
- fi
- done
-}