summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-build/sh-utils/sh-utils-2.0j-r1.ebuild')
-rw-r--r--sys-build/sh-utils/sh-utils-2.0j-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-build/sh-utils/sh-utils-2.0j-r1.ebuild b/sys-build/sh-utils/sh-utils-2.0j-r1.ebuild
new file mode 100644
index 000000000000..bd32af55f05c
--- /dev/null
+++ b/sys-build/sh-utils/sh-utils-2.0j-r1.ebuild
@@ -0,0 +1,40 @@
+
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-build/sh-utils/sh-utils-2.0j-r1.ebuild,v 1.1 2001/01/25 18:00:27 achim Exp $
+
+P=sh-utils-2.0j
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Your standard GNU shell utilities"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
+DEPEND=">=sys-libs/glibc-2.1.3"
+RDEPEND="$DEPEND
+ >=sys-apps/bash-2.04"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ cp sys2.h sys2.h.orig
+ sed -e "s:^char \*strndup://:" sys2.h.orig > sys2.h
+}
+
+src_compile() {
+ export CFLAGS="${CFLAGS}"
+ try ./configure --host=${CHOST} --build=${CHOST} --prefix=/usr \
+ --without-included-regex --disable-nls
+ try make ${MAKEOPTS}
+}
+
+src_install() {
+ try make prefix=${D}/usr install
+ cd ${D}/usr/bin
+ dodir /bin
+ mv date echo false pwd stty su true uname hostname ${D}/bin
+ rm -rf ${D}/usr/lib ${D}/usr/man ${D}/usr/info
+
+}
+
+
+