summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb/gdb-7.6.1.ebuild')
-rw-r--r--sys-devel/gdb/gdb-7.6.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-devel/gdb/gdb-7.6.1.ebuild b/sys-devel/gdb/gdb-7.6.1.ebuild
index a787cad341e3..2d61737dc9d4 100644
--- a/sys-devel/gdb/gdb-7.6.1.ebuild
+++ b/sys-devel/gdb/gdb-7.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.6.1.ebuild,v 1.5 2014/01/14 14:54:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.6.1.ebuild,v 1.6 2014/03/08 23:09:01 vapier Exp $
EAPI="3"
@@ -52,12 +52,13 @@ SLOT="0"
if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="+client expat multitarget nls +python +server test vanilla zlib"
+IUSE="+client expat lzma multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
sys-libs/readline
expat? ( dev-libs/expat )
+ lzma? ( app-arch/xz-utils )
python? ( =dev-lang/python-2* )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
@@ -131,6 +132,7 @@ src_configure() {
--with-system-readline
--with-separate-debug-dir="${EPREFIX}"/usr/lib/debug
$(use_with expat)
+ $(use_with lzma)
$(use_enable nls)
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPREFIX}/usr/bin/python2")