summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/lufs/lufs-0.9.4.ebuild')
-rw-r--r--sys-fs/lufs/lufs-0.9.4.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-fs/lufs/lufs-0.9.4.ebuild b/sys-fs/lufs/lufs-0.9.4.ebuild
new file mode 100644
index 000000000000..6ed55a9866d1
--- /dev/null
+++ b/sys-fs/lufs/lufs-0.9.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lufs/lufs-0.9.4.ebuild,v 1.1 2003/09/15 17:46:25 seemant Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="User-mode filesystem implementation"
+SRC_URI="mirror://sourceforge/lufs/${P}.tar.gz"
+HOMEPAGE="http://lufs.sourceforge.net/lufs/"
+LICENSE="GPL-2"
+DEPEND="virtual/linux-sources"
+#RDEPEND
+KEYWORDS="x86 amd64"
+SLOT="0"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/lufsd
+ mv Makefile.in Makefile.in.orig
+ sed -e 's/install-exec-hook//' Makefile.in.orig > Makefile.in || die
+
+ cd ${S}/util
+ mv Makefile.in Makefile.in.orig
+ sed -e 's/install-exec-hook//' Makefile.in.orig > Makefile.in || die
+
+ cd ${S}/kernel/Linux/2.4
+ mv Makefile.in Makefile.in.orig
+ sed -e 's/install-data-hook//' Makefile.in.orig > Makefile.in || die
+}
+
+src_install () {
+ dodoc AUTHORS COPYING ChangeLog Contributors INSTALL \
+ NEWS README THANKS TODO
+ dohtml docs/lufs.html
+ make DESTDIR=${D} install
+
+ dosym /usr/bin/auto.sshfs /etc/auto.sshfs
+ dosym /usr/bin/auto.ftpfs /etc/auto.ftpfs
+ dodir /sbin
+ dosym /usr/bin/lufsd /sbin/mount.lufs
+}
+
+pkg_postinst() {
+ /usr/sbin/update-modules
+ einfo If you want regular users to be able to mount lufs filesystems,
+ einfo you need to run the following command as root:
+ einfo \# chmod +s /usr/bin/lufsmnt /usr/bin/lufsumount
+}
+
+pkg_postrm() {
+ /sbin/modprobe -r lufs
+}