summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/cpufreqd/cpufreqd-2.1.1.ebuild')
-rw-r--r--sys-power/cpufreqd/cpufreqd-2.1.1.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild b/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild
deleted file mode 100644
index 13b808d48864..000000000000
--- a/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild,v 1.10 2010/06/27 18:02:36 ssuominen Exp $
-
-inherit eutils
-
-NVCLOCK_VERSION="0.8b"
-
-DESCRIPTION="CPU Frequency Daemon"
-HOMEPAGE="http://cpufreqd.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
- nvidia? ( http://www.linuxhardware.org/nvclock/nvclock${NVCLOCK_VERSION}.tar.gz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="ppc"
-
-IUSE="acpi apm nforce2 nvidia pmu"
-RDEPEND=">=sys-power/cpufrequtils-002"
-DEPEND="sys-apps/sed
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
-
- sed -i -e "s:acpi_event:acpi:" "${S}"/cpufreqd.conf
-
- if use nvidia; then
- cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
- epatch "${FILESDIR}"/nvclock${NVCLOCK_VERSION}-fd.patch
- epatch "${FILESDIR}"/nvclock${NVCLOCK_VERSION}-fpic.patch
- fi
-}
-
-src_compile() {
- local config
-
- if use nvidia; then
- cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
- econf \
- --disable-gtk \
- --disable-qt \
- --disable-nvcontrol \
- || die "econf nvclock failed"
- emake -j1 || die "emake nvclock failed"
- config="--enable-nvclock=${WORKDIR}/nvclock${NVCLOCK_VERSION}"
- fi
-
- cd "${S}"
- econf \
- $(use_enable acpi) \
- $(use_enable apm) \
- --disable-sensors \
- $(use_enable nforce2) \
- $(use_enable pmu) \
- ${config} \
- || die "econf failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- dodoc AUTHORS ChangeLog NEWS README TODO
-
- newinitd "${FILESDIR}"/${PN}-init.d ${PN}
-}