summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/phpBB/phpBB-3.0.1.ebuild')
-rw-r--r--www-apps/phpBB/phpBB-3.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/www-apps/phpBB/phpBB-3.0.1.ebuild b/www-apps/phpBB/phpBB-3.0.1.ebuild
new file mode 100644
index 000000000000..0c196532f3ac
--- /dev/null
+++ b/www-apps/phpBB/phpBB-3.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpBB/phpBB-3.0.1.ebuild,v 1.1 2008/04/25 12:02:59 hollow Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="phpBB is an open-source bulletin board package."
+HOMEPAGE="http://www.phpbb.com/"
+SRC_URI="http://www.phpbb.com/files/releases/${P}.tar.bz2
+ mirror://sourceforge/phpbb/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/${PN}3
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc docs/*
+ rm -rf docs
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/cache
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/images/avatars/upload
+ webapp_serverowned "${MY_HTDOCSDIR}"/store
+ webapp_serverowned "${MY_HTDOCSDIR}"/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}