summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/chromium/chromium-9999.ebuild')
-rw-r--r--www-client/chromium/chromium-9999.ebuild18
1 files changed, 15 insertions, 3 deletions
diff --git a/www-client/chromium/chromium-9999.ebuild b/www-client/chromium/chromium-9999.ebuild
index 68efae9330dc..1974b32d1e4b 100644
--- a/www-client/chromium/chromium-9999.ebuild
+++ b/www-client/chromium/chromium-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.103 2010/11/07 17:41:17 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.104 2010/11/07 18:53:35 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
-inherit eutils flag-o-matic multilib pax-utils python subversion toolchain-funcs
+inherit eutils flag-o-matic multilib pax-utils portability python subversion toolchain-funcs
DESCRIPTION="Open-source version of Google Chrome web browser"
HOMEPAGE="http://chromium.org/"
@@ -50,7 +50,6 @@ RDEPEND+="
x11-themes/tango-icon-theme
x11-themes/xfce4-icon-theme
)
- x11-apps/xmessage
x11-misc/xdg-utils
virtual/ttf-fonts
gecko-mediaplayer? ( !www-plugins/gecko-mediaplayer[gnome] )"
@@ -116,6 +115,19 @@ pkg_setup() {
# Make sure the build system will use the right python, bug #344367.
python_set_active_version 2
+
+ # Prevent user problems like bug #299777.
+ if ! grep -q /dev/shm <<< $(get_mounts); then
+ ewarn "You don't have tmpfs mounted at /dev/shm."
+ ewarn "${PN} may fail to start in that configuration."
+ ewarn "Please uncomment the /dev/shm entry in /etc/fstab,"
+ ewarn "and run 'mount /dev/shm'."
+ fi
+ if [ `stat -c %a /dev/shm` -ne 1777 ]; then
+ ewarn "/dev/shm does not have correct permissions."
+ ewarn "${PN} may fail to start in that configuration."
+ ewarn "Please run 'chmod 1777 /dev/shm'."
+ fi
}
src_prepare() {