summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/tornado/tornado-3.2.1.ebuild')
-rw-r--r--www-servers/tornado/tornado-3.2.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/www-servers/tornado/tornado-3.2.1.ebuild b/www-servers/tornado/tornado-3.2.1.ebuild
index ac2c22dd8866..4bfd14aa5211 100644
--- a/www-servers/tornado/tornado-3.2.1.ebuild
+++ b/www-servers/tornado/tornado-3.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tornado/tornado-3.2.1.ebuild,v 1.3 2014/08/13 18:24:16 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tornado/tornado-3.2.1.ebuild,v 1.4 2014/09/02 09:35:56 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
@@ -13,7 +13,9 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
+
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
IUSE="curl test"
REQUIRED_USE="curl? ( || ( $(python_gen_useflags 'python2*') ) )"
@@ -25,8 +27,7 @@ DEPEND="${RDEPEND}
test? (
dev-python/mock[${PYTHON_USEDEP}]
python_targets_python2_7? ( dev-python/twisted-names[python_targets_python2_7] )
- )
-"
+ )"
src_test() {
# The test server tries to bind at an unused port but suffers