summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/x2vnc/x2vnc-1.7.1.ebuild')
-rw-r--r--x11-misc/x2vnc/x2vnc-1.7.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/x2vnc/x2vnc-1.7.1.ebuild b/x11-misc/x2vnc/x2vnc-1.7.1.ebuild
new file mode 100644
index 000000000000..16b023256aca
--- /dev/null
+++ b/x11-misc/x2vnc/x2vnc-1.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2vnc/x2vnc-1.7.1.ebuild,v 1.1 2006/05/22 08:56:50 phosphan Exp $
+
+DESCRIPTION="Control a remote computer running VNC from X"
+HOMEPAGE="http://fredrik.hubbe.net/x2vnc.html"
+SRC_URI="http://fredrik.hubbe.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="tcltk"
+
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXext
+ x11-libs/libXinerama )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/scrnsaverproto
+ x11-proto/xproto
+ x11-proto/xineramaproto )
+ virtual/x11 )
+ tcltk? ( dev-tcltk/expect )"
+
+src_install() {
+ dodir /usr/share /usr/bin
+ make DESTDIR=${D} install || die
+ use tcltk && dobin contrib/tkx2vnc
+ dodoc ChangeLog README
+}