summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/msn-pecan/msn-pecan-0.1.0_rc2.ebuild')
-rw-r--r--x11-plugins/msn-pecan/msn-pecan-0.1.0_rc2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-plugins/msn-pecan/msn-pecan-0.1.0_rc2.ebuild b/x11-plugins/msn-pecan/msn-pecan-0.1.0_rc2.ebuild
new file mode 100644
index 000000000000..8e7ddd2e2c18
--- /dev/null
+++ b/x11-plugins/msn-pecan/msn-pecan-0.1.0_rc2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/msn-pecan/msn-pecan-0.1.0_rc2.ebuild,v 1.1 2009/12/24 11:28:33 pva Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="Alternative MSN protocol plugin for libpurple"
+HOMEPAGE="http://code.google.com/p/msn-pecan/"
+
+SRC_URI="http://msn-pecan.googlecode.com/files/${P/_/-}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P/_/-}
+
+src_prepare() {
+ sed -e "/^LDFLAGS/{s/$/ ${LDFLAGS}/;}" \
+ -e "/^CFLAGS/{s/$/ ${CFLAGS}/;}" -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS=${LDFLAGS} || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "Select the 'WLM' protocol to use this plugin"
+ einfo
+ elog "For more information (how to change personal message, add"
+ elog "missing emoticons, ...), please read:"
+ elog "http://code.google.com/p/msn-pecan/wiki/FAQ"
+}