aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-base/xorg-server/xorg-server-9999.ebuild')
-rw-r--r--x11-base/xorg-server/xorg-server-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/x11-base/xorg-server/xorg-server-9999.ebuild b/x11-base/xorg-server/xorg-server-9999.ebuild
index 03e102d..513ee00 100644
--- a/x11-base/xorg-server/xorg-server-9999.ebuild
+++ b/x11-base/xorg-server/xorg-server-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
EAPI=5
@@ -13,7 +13,7 @@ SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
IUSE_SERVERS="dmx kdrive xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} extra-warn glamor glx ipv6 minimal nptl selinux +suid systemd tslib +udev unwind wayland"
+IUSE="${IUSE_SERVERS} drm extra-warn glamor glx ipv6 minimal nptl selinux +suid systemd tslib +udev unwind wayland"
CDEPEND=">=app-eselect/eselect-opengl-1.3.0
dev-libs/openssl
@@ -22,7 +22,6 @@ CDEPEND=">=app-eselect/eselect-opengl-1.3.0
>=x11-apps/rgb-1.0.3
>=x11-apps/xauth-1.0.3
x11-apps/xkbcomp
- >=x11-libs/libdrm-2.4.46
>=x11-libs/libpciaccess-0.12.901
>=x11-libs/libXau-1.0.4
>=x11-libs/libXdmcp-1.0.2
@@ -46,6 +45,7 @@ CDEPEND=">=app-eselect/eselect-opengl-1.3.0
>=x11-libs/libXres-1.0.3
>=x11-libs/libXtst-1.0.99.2
)
+ drm? ( >=x11-libs/libdrm-2.4.46 )
glamor? (
media-libs/libepoxy
>=media-libs/mesa-10.3.4-r1[egl,gbm]
@@ -145,6 +145,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
# needed for new eselect-opengl, bug #541232
"${FILESDIR}"/${PN}-1.17-support-multiple-Files-sections.patch
+ "${FILESDIR}"/${PN}-1.17.2-uninit-clientsWritable.patch
"${FILESDIR}"/${PN}-fix_stupid_array_bounds_warning.patch
"${FILESDIR}"/${PN}-fix_declaration_mismatch.patch
)
@@ -174,9 +175,6 @@ src_configure() {
# sysconfdir is used for the xorg.conf location; same applies
# NOTE: fop is used for doc generating ; and i have no idea if gentoo
# package it somewhere
-
- # should try $(use_enable dri3) some day...
-
XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
$(use_enable dmx)
@@ -206,7 +204,7 @@ src_configure() {
$(use_with systemd systemd-daemon)
$(use_enable systemd systemd-logind)
$(use_enable extra-warn selective-werror)
- --enable-libdrm
+ $(use_enable drm libdrm)
--sysconfdir="${EPREFIX}"/etc/X11
--localstatedir="${EPREFIX}"/var
--with-fontrootdir="${EPREFIX}"/usr/share/fonts