aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-05-10 23:17:22 -0400
committerMike Gilbert <floppym@gentoo.org>2016-05-10 23:27:55 -0400
commitc621dca0acccb146926e8950012aa331f2cb0bfe (patch)
tree6973a11794d408e9e44b86ea6ad688b92606034f
parentebuild-test/invalidname: rename from 'invalid' (diff)
downloadgen-b0rk-c621dca0acccb146926e8950012aa331f2cb0bfe.tar.gz
gen-b0rk-c621dca0acccb146926e8950012aa331f2cb0bfe.tar.bz2
gen-b0rk-c621dca0acccb146926e8950012aa331f2cb0bfe.zip
ebuild-test/variable-readonly: test for variable.readonly
-rw-r--r--ebuild-test/variable-readonly/metadata.xml26
-rw-r--r--ebuild-test/variable-readonly/variable-readonly-0.ebuild16
2 files changed, 42 insertions, 0 deletions
diff --git a/ebuild-test/variable-readonly/metadata.xml b/ebuild-test/variable-readonly/metadata.xml
new file mode 100644
index 0000000..da7c4a8
--- /dev/null
+++ b/ebuild-test/variable-readonly/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+# $Id$
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>exampledev@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<maintainer type="project">
+ <email>exampleproject@gentoo.org</email>
+ <name>Gentoo Example Project</name>
+</maintainer>
+<longdescription>Test for ???</longdescription>
+</pkgmetadata>
diff --git a/ebuild-test/variable-readonly/variable-readonly-0.ebuild b/ebuild-test/variable-readonly/variable-readonly-0.ebuild
new file mode 100644
index 0000000..56f72fe
--- /dev/null
+++ b/ebuild-test/variable-readonly/variable-readonly-0.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Assignment to read-only variables"
+HOMEPAGE="http://example.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+P=foo
+export P=foo
+EPREFIX=foo