aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-26 01:46:53 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-26 01:46:53 +0200
commit3067d4b62465187667888adc9376218d937cbc15 (patch)
tree4c6490c0425218600e8d7035c7ad5856a9832ebd /CONTRIBUTING.md
parentTODO.md: remove otf2 (diff)
downloadguru-3067d4b62465187667888adc9376218d937cbc15.tar.gz
guru-3067d4b62465187667888adc9376218d937cbc15.tar.bz2
guru-3067d4b62465187667888adc9376218d937cbc15.zip
CONTRIBUTING.md: add list of undesired python dependencies
Closes: https://github.com/gentoo/guru/issues/11 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'CONTRIBUTING.md')
-rw-r--r--CONTRIBUTING.md17
1 files changed, 16 insertions, 1 deletions
diff --git a/CONTRIBUTING.md b/CONTRIBUTING.md
index 6579620e7..0fcc70708 100644
--- a/CONTRIBUTING.md
+++ b/CONTRIBUTING.md
@@ -32,7 +32,22 @@ Please don't use symlinks in the repository (e.g. foobar-x.y.z.ebuild -> foobar-
Sometimes a upstream lists dependencies which are considered deprecated. If possible, packages should **not** depend on these deprecated dependencies. Reasons a dependency might be deprecated is that it is too old, unmaintained, or the features it adds are not useful to Gentoo. You can find an overview of the currently deprecated dependencies and the reason they are deprecated in `$(portageq get_repo_path / gentoo)/profiles/package.deprecated`. `repoman -dx full` will warn you if your package depends on a deprecated dependency.
-For Python packages there are some additional (test) dependencies that are considered undesirable or not useful, but are not considered deprecated. You can find an overview of those [here](https://dev.gentoo.org/~mgorny/python-guide/distutils.html#enabling-tests).
+For Python packages there are some additional (test) dependencies that are considered undesirable or not useful, but are not considered deprecated. You can find an overview of those [here](https://dev.gentoo.org/~mgorny/python-guide/distutils.html#enabling-tests) and in the list below:
+- dev-python/black
+- dev-python/check-manifest
+- dev-python/coverage
+- dev-python/docutils
+- dev-python/flake8
+- dev-python/isort
+- dev-python/mypy
+- dev-python/multilint
+- dev-python/pep8
+- dev-python/pycodestyle
+- dev-python/pytest-cov
+- dev-python/pytest-runner
+- dev-python/readme_renderer
+- dev-python/tox
+- dev-python/twine
- #### Licenses of bundled libraries