aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-08-04 15:00:27 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-08-04 18:29:35 +0900
commitf20b97c114eca3118be64d08ab046e3edd2a3aa5 (patch)
tree56e8ef25651f0e52ed95926a1acd83e95da1e94d /dev-cpp
parentsys-apps/dnf5: block >=dev-cpp/toml11-4.0.0 (diff)
downloadguru-f20b97c114eca3118be64d08ab046e3edd2a3aa5.tar.gz
guru-f20b97c114eca3118be64d08ab046e3edd2a3aa5.tar.bz2
guru-f20b97c114eca3118be64d08ab046e3edd2a3aa5.zip
dev-cpp/toml11: add 4.1.0
Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/toml11/Manifest1
-rw-r--r--dev-cpp/toml11/files/toml11-4.1.0-system-doctest.patch410
-rw-r--r--dev-cpp/toml11/files/toml11-4.1.0-werror.patch11
-rw-r--r--dev-cpp/toml11/toml11-4.1.0.ebuild32
4 files changed, 454 insertions, 0 deletions
diff --git a/dev-cpp/toml11/Manifest b/dev-cpp/toml11/Manifest
index 55d040904..5664ddec5 100644
--- a/dev-cpp/toml11/Manifest
+++ b/dev-cpp/toml11/Manifest
@@ -1,2 +1,3 @@
DIST toml-0.5.0.tar.gz 1609475 BLAKE2B ed9c2fd5f885411c9a607b84a0c484c8ad3d26c16cdf31b5800be74c928b15faaa1cad53c913d5f43c74bce260ed10f74a1b81d72679eca291a9de503414fdda SHA512 5a84a2704ee0bffefcf27ef15a45689ca3d76350842e16c2c847500c4420a22254e78804f3b26005fec17263a4717bd01127a53e56335fe2a3c828cc02e75d37
DIST toml11-3.8.1.tar.gz 135565 BLAKE2B 96cf39e097e8fc587faab980f993c36f720ca6185938accd4200277380a189fd8604d04f3a24fe06a6cc4708e23e5271d930135d2be9b6fb37b56ad1a845f1c1 SHA512 74a70abe413e21b94284242c281645c49f08b930c62f5479e6698cee45a99b56511d0a8888f1f6f2af3fc245bb0dfd5048a0b810b474ca1066211e25a1ce33bb
+DIST toml11-4.1.0.tar.gz 342303 BLAKE2B 969fd0187d23c2525e4979773989fcd24446e14671b9cf829c48590e0e4e15d7e9514348b560bc552a7891d54da80b808d081b8a44fe6a0cad7f8cd71c496055 SHA512 b9755fc434ba8e1ada2f42d37d1bdde084d9bb0ac9300e87113fd5a1fb3095381c745797e8646c3cccec6769f07b03f724823253ccb50e8f36c604ea9452df66
diff --git a/dev-cpp/toml11/files/toml11-4.1.0-system-doctest.patch b/dev-cpp/toml11/files/toml11-4.1.0-system-doctest.patch
new file mode 100644
index 000000000..fce2e9876
--- /dev/null
+++ b/dev-cpp/toml11/files/toml11-4.1.0-system-doctest.patch
@@ -0,0 +1,410 @@
+unbundle doctest
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -43,15 +43,16 @@ set(TOML11_TEST_NAMES
+
+ if(BUILD_TESTING)
+ add_library(toml11_test_utility STATIC utility.cpp)
++ find_package(doctest REQUIRED)
+ target_include_directories(toml11_test_utility
+- PRIVATE ${PROJECT_SOURCE_DIR}/tests/extlib/doctest/doctest/
++ PRIVATE ${DOCTEST_INCLUDE_DIR}
+ )
+ target_link_libraries(toml11_test_utility PUBLIC toml11)
+
+ foreach(TEST_NAME ${TOML11_TEST_NAMES})
+ add_executable(${TEST_NAME} ${TEST_NAME}.cpp)
+ target_include_directories(${TEST_NAME}
+- PRIVATE ${PROJECT_SOURCE_DIR}/tests/extlib/doctest/doctest/
++ PRIVATE ${DOCTEST_INCLUDE_DIR}
+ )
+ target_link_libraries(${TEST_NAME} PUBLIC toml11 toml11_test_utility)
+ if(MSVC)
+--- a/tests/test_comments.cpp
++++ b/tests/test_comments.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml.hpp>
+
+--- a/tests/test_datetime.cpp
++++ b/tests/test_datetime.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml11/datetime.hpp>
+
+--- a/tests/test_error_message.cpp
++++ b/tests/test_error_message.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml.hpp>
+
+--- a/tests/test_find.cpp
++++ b/tests/test_find.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_find_or.cpp
++++ b/tests/test_find_or.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_format_floating.cpp
++++ b/tests/test_format_floating.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml11/parser.hpp>
+ #include <toml11/serializer.hpp>
+--- a/tests/test_format_integer.cpp
++++ b/tests/test_format_integer.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml11/parser.hpp>
+ #include <toml11/serializer.hpp>
+--- a/tests/test_format_table.cpp
++++ b/tests/test_format_table.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml11/parser.hpp>
+ #include <toml11/serializer.hpp>
+--- a/tests/test_get.cpp
++++ b/tests/test_get.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_get_or.cpp
++++ b/tests/test_get_or.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_literal.cpp
++++ b/tests/test_literal.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <iostream>
+
+--- a/tests/test_location.cpp
++++ b/tests/test_location.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml11/location.hpp>
+
+--- a/tests/test_parse_array.cpp
++++ b/tests/test_parse_array.cpp
+@@ -5,7 +5,7 @@
+ #include <toml11/parser.hpp>
+ #include <toml11/types.hpp>
+
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ TEST_CASE("testing an array")
+ {
+--- a/tests/test_parse_boolean.cpp
++++ b/tests/test_parse_boolean.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_parse_datetime.cpp
++++ b/tests/test_parse_datetime.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_parse_floating.cpp
++++ b/tests/test_parse_floating.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_parse_inline_table.cpp
++++ b/tests/test_parse_inline_table.cpp
+@@ -5,7 +5,7 @@
+ #include <toml11/parser.hpp>
+ #include <toml11/types.hpp>
+
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ TEST_CASE("testing an inline table v1.0")
+ {
+--- a/tests/test_parse_integer.cpp
++++ b/tests/test_parse_integer.cpp
+@@ -1,6 +1,6 @@
+
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_parse_null.cpp
++++ b/tests/test_parse_null.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_parse_string.cpp
++++ b/tests/test_parse_string.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+ #include <iostream>
+--- a/tests/test_parse_table.cpp
++++ b/tests/test_parse_table.cpp
+@@ -5,7 +5,7 @@
+ #include <toml11/parser.hpp>
+ #include <toml11/types.hpp>
+
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ TEST_CASE("testing a table")
+ {
+--- a/tests/test_parse_table_keys.cpp
++++ b/tests/test_parse_table_keys.cpp
+@@ -5,7 +5,7 @@
+ #include <toml11/parser.hpp>
+ #include <toml11/types.hpp>
+
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ TEST_CASE("testing table keys")
+ {
+--- a/tests/test_result.cpp
++++ b/tests/test_result.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml11/result.hpp>
+
+--- a/tests/test_scanner.cpp
++++ b/tests/test_scanner.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_serialize.cpp
++++ b/tests/test_serialize.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml.hpp>
+
+--- a/tests/test_spec.cpp
++++ b/tests/test_spec.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml11/spec.hpp>
+
+--- a/tests/test_storage.cpp
++++ b/tests/test_storage.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml11/storage.hpp>
+
+--- a/tests/test_syntax_boolean.cpp
++++ b/tests/test_syntax_boolean.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_syntax_comment.cpp
++++ b/tests/test_syntax_comment.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_syntax_datetime.cpp
++++ b/tests/test_syntax_datetime.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_syntax_floating.cpp
++++ b/tests/test_syntax_floating.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_syntax_integer.cpp
++++ b/tests/test_syntax_integer.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_syntax_key.cpp
++++ b/tests/test_syntax_key.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_syntax_string.cpp
++++ b/tests/test_syntax_string.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_traits.cpp
++++ b/tests/test_traits.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml11/types.hpp>
+
+--- a/tests/test_types.cpp
++++ b/tests/test_types.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml11/types.hpp>
+
+--- a/tests/test_user_defined_conversion.cpp
++++ b/tests/test_user_defined_conversion.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml.hpp>
+ #include "utility.hpp"
+--- a/tests/test_utility.cpp
++++ b/tests/test_utility.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml11/utility.hpp>
+
+--- a/tests/test_value.cpp
++++ b/tests/test_value.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/test_visit.cpp
++++ b/tests/test_visit.cpp
+@@ -1,5 +1,5 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <toml11/comments.hpp>
+ #include <toml11/types.hpp>
+--- a/tests/utility.cpp
++++ b/tests/utility.cpp
+@@ -1,4 +1,4 @@
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include "utility.hpp"
+
+--- a/tests/utility.hpp
++++ b/tests/utility.hpp
+@@ -9,7 +9,7 @@
+ #include <toml11/serializer.hpp>
+ #include <toml11/value.hpp>
+
+-#include "doctest.h"
++#include <doctest/doctest.h>
+
+ #include <ostream>
+ #include <string>
diff --git a/dev-cpp/toml11/files/toml11-4.1.0-werror.patch b/dev-cpp/toml11/files/toml11-4.1.0-werror.patch
new file mode 100644
index 000000000..df06c2acb
--- /dev/null
+++ b/dev-cpp/toml11/files/toml11-4.1.0-werror.patch
@@ -0,0 +1,11 @@
+unset Werror
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -44,7 +44,6 @@ include(CheckCXXCompilerFlag)
+ check_cxx_compiler_flag("-Wall" TOML11_COMPILER_SUPPORTS_WALL)
+ check_cxx_compiler_flag("-Wextra" TOML11_COMPILER_SUPPORTS_WEXTRA)
+ check_cxx_compiler_flag("-Wpedantic" TOML11_COMPILER_SUPPORTS_WPEDANTIC)
+-check_cxx_compiler_flag("-Werror" TOML11_COMPILER_SUPPORTS_WERROR)
+ check_cxx_compiler_flag("-Wsign-conversion" TOML11_COMPILER_SUPPORTS_WSIGN_CONVERSION)
+ check_cxx_compiler_flag("-Wconversion" TOML11_COMPILER_SUPPORTS_WCONVERSION)
+ check_cxx_compiler_flag("-Wduplicated-cond" TOML11_COMPILER_SUPPORTS_WDUPLICATED_COND)
diff --git a/dev-cpp/toml11/toml11-4.1.0.ebuild b/dev-cpp/toml11/toml11-4.1.0.ebuild
new file mode 100644
index 000000000..3cca5429d
--- /dev/null
+++ b/dev-cpp/toml11/toml11-4.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="TOML for Modern C++"
+HOMEPAGE="https://github.com/ToruNiina/toml11"
+SRC_URI="https://github.com/ToruNiina/toml11/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/doctest )"
+
+PATCHES=(
+ # unbundle doctest
+ "${FILESDIR}/${P}-system-doctest.patch"
+ # unset Werror
+ "${FILESDIR}/${P}-werror.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DTOML11_BUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}