aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-09-04 12:55:24 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-09-04 12:58:34 +0200
commitefa9fe9bbd8d982978e21a116f4c7b2450aa7b0c (patch)
treea663052c200c41b69bceef8141f9ed774af2e4d9 /dev-dotnet
parentdev-embedded/esp-idf-kconfig: add 1.2.0 (diff)
downloadguru-efa9fe9bbd8d982978e21a116f4c7b2450aa7b0c.tar.gz
guru-efa9fe9bbd8d982978e21a116f4c7b2450aa7b0c.tar.bz2
guru-efa9fe9bbd8d982978e21a116f4c7b2450aa7b0c.zip
dev-dotnet/gtk-sharp: add version 3.22.2
Borrowed from the ::fritteli overlay Required for picoscope 7 in ::natinst Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/gtk-sharp/Manifest1
-rw-r--r--dev-dotnet/gtk-sharp/files/01-meson-build-gio.patch11
-rw-r--r--dev-dotnet/gtk-sharp/gtk-sharp-3.22.2-r2.ebuild57
-rw-r--r--dev-dotnet/gtk-sharp/metadata.xml5
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-dotnet/gtk-sharp/Manifest b/dev-dotnet/gtk-sharp/Manifest
index af5352df4..717b88961 100644
--- a/dev-dotnet/gtk-sharp/Manifest
+++ b/dev-dotnet/gtk-sharp/Manifest
@@ -1 +1,2 @@
DIST gtk-sharp-2.99.3.tar.gz 2319079 BLAKE2B 8af1fd7123ba4e4c17e54d9e87e615c38574c8db23a87374c17b8600f8c5c01e649246eb819930d32c9e0708f562618e0be3cf35a44ee6feeb4e5029eedbba19 SHA512 df643edbe61eeea9f12349b5f467e8bb5eb68e72f2d6b9978daed42a5deff1ca33b1869c7a24f4c15bdc472bc368e7432ad18e7db6e0b39cd93eacdcc750efd9
+DIST gtk-sharp-3.22.2.tar.gz 3297236 BLAKE2B ed6f9e19cc2db3e3a86a14107239b25ec4868222d5ef3d694372e824b8f323d70f5a4847c72a0c2a780cc474375fbf74c74ca3165fbed4255e68671614b9f9fc SHA512 8d4fdcbd54ec795dd5d8bd1fd9e4ec5ea5fff5169392891c99656d3fa1fffda28bbe6ac4e32f1201e7ed03b9702f37e85cd315946bf055efdd7b264d23e6007a
diff --git a/dev-dotnet/gtk-sharp/files/01-meson-build-gio.patch b/dev-dotnet/gtk-sharp/files/01-meson-build-gio.patch
new file mode 100644
index 000000000..be23b163f
--- /dev/null
+++ b/dev-dotnet/gtk-sharp/files/01-meson-build-gio.patch
@@ -0,0 +1,11 @@
+diff --git a/Source/gio/generated/meson.build b/Source/gio/generated/meson.build
+index f8e3978..416ed5c 100644
+--- a/Source/gio/generated/meson.build
++++ b/Source/gio/generated/meson.build
+@@ -413,5 +413,5 @@ pkgs += [pkg]
+ source_gen = files(generated_sources)
+ gio_api_includes = join_paths(meson.current_source_dir(), 'gio-api.xml')
+ if install
+- install_data(gdk_api_includes, install_dir: gapi_xml_installdir)
++ install_data(gio_api_includes, install_dir: gapi_xml_installdir)
+ endif
diff --git a/dev-dotnet/gtk-sharp/gtk-sharp-3.22.2-r2.ebuild b/dev-dotnet/gtk-sharp/gtk-sharp-3.22.2-r2.ebuild
new file mode 100644
index 000000000..fddc5d664
--- /dev/null
+++ b/dev-dotnet/gtk-sharp/gtk-sharp-3.22.2-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+MY_PN="GtkSharp"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="gtk bindings for mono"
+HOMEPAGE="https://github.com/GLibSharp/GtkSharp"
+SRC_URI="https://github.com/GLibSharp/GtkSharp/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+SLOT="3"
+IUSE="+atk +cairo +gdk +gtk +pango"
+
+REQUIRED_USE="
+ gdk? ( atk cairo pango )
+ gtk? ( atk cairo gdk pango )
+ pango? ( cairo )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.32
+ x11-libs/gtk+:3
+"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/mono-6.12
+ atk? ( app-accessibility/at-spi2-core )
+ cairo? ( x11-libs/cairo )
+ gdk? ( x11-libs/gdk-pixbuf )
+ gtk? ( x11-libs/gtk+:3 )
+ pango? ( x11-libs/pango )"
+
+PATCHES=( "${FILESDIR}/01-meson-build-gio.patch" )
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature atk)
+ $(meson_feature cairo)
+ $(meson_feature gdk)
+ $(meson_feature gtk)
+ $(meson_feature pango)
+ -Dinstall=true
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}
diff --git a/dev-dotnet/gtk-sharp/metadata.xml b/dev-dotnet/gtk-sharp/metadata.xml
index 48d860dab..08aa5909d 100644
--- a/dev-dotnet/gtk-sharp/metadata.xml
+++ b/dev-dotnet/gtk-sharp/metadata.xml
@@ -2,6 +2,11 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
+ <use>
+ <flag name="atk">Build the ATK bindings.</flag>
+ <flag name="gdk">Build the GDK bindings.</flag>
+ <flag name="pango">Build the Pango bindings.</flag>
+ </use>
<upstream>
<remote-id type="github">mono/gtk-sharp</remote-id>
</upstream>