aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2023-09-14 16:58:08 +0200
committerDavid Roman <davidroman96@gmail.com>2023-09-14 16:58:08 +0200
commit255c80f5361a896540f95d00b296b20940b641f6 (patch)
tree3b1aaba9c07d8c62159a0f3d010c4ec8489948f2 /dev-python/adb-shell
parentdev-python/adb-shell: update HOMEPAGE (diff)
downloadguru-255c80f5361a896540f95d00b296b20940b641f6.tar.gz
guru-255c80f5361a896540f95d00b296b20940b641f6.tar.bz2
guru-255c80f5361a896540f95d00b296b20940b641f6.zip
dev-python/adb-shell: add 0.4.4
Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-python/adb-shell')
-rw-r--r--dev-python/adb-shell/adb-shell-0.4.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/adb-shell/adb-shell-0.4.4.ebuild b/dev-python/adb-shell/adb-shell-0.4.4.ebuild
new file mode 100644
index 000000000..5b0420c77
--- /dev/null
+++ b/dev-python/adb-shell/adb-shell-0.4.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python implementation of ADB with shell and FileSync functionality."
+HOMEPAGE="https://pypi.org/project/adb-shell/ https://github.com/JeffLIrion/adb_shell"
+SRC_URI="https://github.com/JeffLIrion/adb_shell/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/adb_shell-${PV}"
+
+RDEPEND="
+ dev-python/aiofiles[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+"
+DEPEND="test? (
+ ${RDEPEND}
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/libusb1[${PYTHON_USEDEP}]
+
+)"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+distutils_enable_tests unittest