aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-03-20 01:42:13 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-03-20 01:42:13 +0400
commit0d4c5ba2b199f3b849409a9bc0d15f49f80c614c (patch)
treed4db8aa31a91eb536a5cd949074e034ec1fd68f7 /games-emulation
parentnet-im/mautrix-signal: remove redundant BDEPEND (diff)
downloadguru-0d4c5ba2b199f3b849409a9bc0d15f49f80c614c.tar.gz
guru-0d4c5ba2b199f3b849409a9bc0d15f49f80c614c.tar.bz2
guru-0d4c5ba2b199f3b849409a9bc0d15f49f80c614c.zip
games-emulation/conty: bump
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/conty/conty-1.25.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-emulation/conty/conty-1.25.2.ebuild b/games-emulation/conty/conty-1.25.2.ebuild
new file mode 100644
index 000000000..eb20204d5
--- /dev/null
+++ b/games-emulation/conty/conty-1.25.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Easy to use unprivileged Linux container packed in a single portable executable"
+HOMEPAGE="https://github.com/Kron4ek/Conty"
+
+inherit linux-info
+
+NAME="${PN}_lite_dwarfs.sh"
+
+SRC_URI="https://github.com/Kron4ek/Conty/releases/download/${PV}/${NAME}"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+RESTRICT="strip"
+
+RDEPEND="sys-fs/fuse:0"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="*"
+
+CONFIG_CHECK="
+ IA32_EMULATION
+ USER_NS
+"
+
+src_install() {
+ dobin "${DISTDIR}/${PN}_lite_dwarfs.sh"
+}
+
+pkg_postinst() {
+ einfo "How to use: $ ${NAME} [command] [command_arguments]"
+ einfo "For example: ${NAME} steam"
+ einfo "or"
+ einfo "WINEPREFIX=$HOME/wine-conty ${NAME} gamescope -f -- wine ./game.exe"
+
+}