aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2023-12-11 09:27:00 +0100
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2023-12-11 09:28:25 +0100
commitf6f870830839a83eb7f4fd80ec07972cff27cd2b (patch)
tree6aa4418772e25233b3bd207bcdaca4f0af2bcfdd /games-rpg
parentnet-im/discord-canary-bin: add 0.0.213, drop 0.0.212 (diff)
downloadguru-f6f870830839a83eb7f4fd80ec07972cff27cd2b.tar.gz
guru-f6f870830839a83eb7f4fd80ec07972cff27cd2b.tar.bz2
guru-f6f870830839a83eb7f4fd80ec07972cff27cd2b.zip
games-rpg/open-adventure: add || die to sed calls
Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/open-adventure/open-adventure-1.16.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/games-rpg/open-adventure/open-adventure-1.16.ebuild b/games-rpg/open-adventure/open-adventure-1.16.ebuild
index 45758338c5..144ca6192d 100644
--- a/games-rpg/open-adventure/open-adventure-1.16.ebuild
+++ b/games-rpg/open-adventure/open-adventure-1.16.ebuild
@@ -37,13 +37,13 @@ python_check_deps() {
src_prepare() {
# remove uncommon flags
sed -e 's/-D_FORTIFY_SOURCE=2 -fstack-protector-all $(CFLAGS) -g/$(CFLAGS)/' \
- -i Makefile
+ -i Makefile || die "Makefile patching failed"
eapply_user
# Add missing semicolon
sed -e 's/rspeak(SAVERESUME_DISABLED)/rspeak(SAVERESUME_DISABLED);/' \
- -i saveresume.c
+ -i saveresume.c || die "Typo fix failed"
}
src_compile() {