aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-03-27 08:47:25 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-03-27 08:47:25 +0400
commitc7e792b71fa134334738778f3cf8128b7a4d94cc (patch)
tree61d2707ca0af62c7c22cc43642ed1db15b7518b6 /games-strategy
parentnet-im/mautrix-signal/files: fix initd (diff)
downloadguru-c7e792b71fa134334738778f3cf8128b7a4d94cc.tar.gz
guru-c7e792b71fa134334738778f3cf8128b7a4d94cc.tar.bz2
guru-c7e792b71fa134334738778f3cf8128b7a4d94cc.zip
games-strategy/general: new package
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/general/Manifest1
-rw-r--r--games-strategy/general/general-4.6.ebuild50
-rw-r--r--games-strategy/general/metadata.xml11
3 files changed, 62 insertions, 0 deletions
diff --git a/games-strategy/general/Manifest b/games-strategy/general/Manifest
new file mode 100644
index 000000000..5201bc8ff
--- /dev/null
+++ b/games-strategy/general/Manifest
@@ -0,0 +1 @@
+DIST general-4.6.tar.xz 1370628 BLAKE2B cd7a113e6e4ab322af0abd83da77af809c8774541b1353d11093c246f0e11cb0a914fb6a34e2980f6a0c8f4476b6ba6a4e6f9b4ddafa780bb9ab502f5140f178 SHA512 77acc50d8b41a9cb09a7133843e6bdbedb3a428a54461c990725b436fc8bca9618ca44d6c20ba890676e1f765c31b29e651032fddbf8917c11d09659ed4ec55a
diff --git a/games-strategy/general/general-4.6.ebuild b/games-strategy/general/general-4.6.ebuild
new file mode 100644
index 000000000..b9d598ea6
--- /dev/null
+++ b/games-strategy/general/general-4.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Turn-based, old style with minimum graphic, full game, 5 MB size"
+HOMEPAGE="http://akasoft.genliga.ru/index_e.php"
+
+SRC_URI="https://archive.org/download/general.tar.xz/$P.tar.xz"
+
+KEYWORDS="~amd64"
+S="${WORKDIR}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+RESTRICT="strip"
+
+RDEPEND="
+ ~games-emulation/conty-1.25.2:0
+"
+# TODO add USE flag to be able to choolse local wine or wine-proton, against 1.4 GB dependency?
+
+QA_PREBUILT="*"
+
+src_install() {
+
+ mkdir -p "$ED$/opt" || die
+
+ mkdir "$ED/opt" || die
+ mkdir -p "$ED/usr/bin/" || die
+ cp -r "$PN" "$ED/opt/$PN" || die
+
+ conty='conty-1.25.2'
+
+ echo "cd /opt/$PN; $conty wine $PN; cd -" > "$ED/usr/bin/$PN"
+ fperms +x "/usr/bin/$PN"
+ # I tried this but on run error: "Problems during decoding OGG files" -
+ # because I need to run from the directory of the game,
+ # but cd does not works with exec
+ # make_wrapper "$PN" "$conty wine /opt/$PN/$PN.exe /d /opt/$PN"
+
+}
+
+pkg_postinst() {
+ einfo "More about the game:"
+ einfo "See screenshots at http://akasoft.genliga.ru/rus/about.php"
+ einfo "https://ru.wikipedia.org/wiki/Генерал_(игра)"
+ einfo "https://www.wikidata.org/wiki/Q4043784"
+ einfo "https://www.wikidata.org/wiki/Q4135303"
+}
diff --git a/games-strategy/general/metadata.xml b/games-strategy/general/metadata.xml
new file mode 100644
index 000000000..57d4ed33b
--- /dev/null
+++ b/games-strategy/general/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Vitaly Zdanevich</name>
+ <email>zdanevich.vitaly@ya.ru</email>
+ </maintainer>
+ <upstream>
+ <doc>http://akasoft.genliga.ru/eng/howto.php</doc>
+ </upstream>
+</pkgmetadata>