aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2022-04-15 13:52:11 +0200
committerKurt Kanzenbach <kurt@kmk-computers.de>2022-04-15 17:15:29 +0200
commit3c7a3e701b285e6a2b86dc59e2dc2b5f25285cd9 (patch)
tree18e7f1aaafb9cc4be37a150b5bd368cb84097b83 /net-dialup
parentmedia-sound/nuclear-bin: make QA_PREBUILT relative (diff)
downloadguru-3c7a3e701b285e6a2b86dc59e2dc2b5f25285cd9.tar.gz
guru-3c7a3e701b285e6a2b86dc59e2dc2b5f25285cd9.tar.bz2
guru-3c7a3e701b285e6a2b86dc59e2dc2b5f25285cd9.zip
net-dialup/tio: add 1.37
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/tio-1.37.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
index c6012c49e..e50a50817 100644
--- a/net-dialup/tio/Manifest
+++ b/net-dialup/tio/Manifest
@@ -1 +1,2 @@
DIST tio-1.36.tar.xz 1803668 BLAKE2B b973c3cc344486d78b5634a6929e9b4c9550f5af029c77be70c0f10a1bc4519c4d4b31c3125cfe2a88dbf01d400b3cb74841c06c8831ba677077e8aa57751e00 SHA512 fda643b5ed8f24acfc2b9135cf508acbca1157806de884c152882526688a05e823c7de29196cb94e6bedb025bfda8750d736e07e5b829df784cb7f9042ec214a
+DIST tio-1.37.tar.xz 1804236 BLAKE2B 320ab5955c80551198b24ae9f166a0d41790557755d4cc44149d0aeaabb5a75dfc3e5d29c009b5b985a6788226b63756e4e7588dbb7f658f4b8a8ce99b270bf6 SHA512 207184d297809c7f88185353b55519cf119eed26b5710b644418ef0603d003618c69e593a0f531822c0455a512397cea1b4747a453af5bbb369dad14025b0847
diff --git a/net-dialup/tio/tio-1.37.ebuild b/net-dialup/tio/tio-1.37.ebuild
new file mode 100644
index 000000000..aa1af5f4e
--- /dev/null
+++ b/net-dialup/tio/tio-1.37.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/inih
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}