aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2022-06-04 13:47:07 +0200
committerKurt Kanzenbach <kurt@kmk-computers.de>2022-06-04 13:47:07 +0200
commit48ebdf539be5c7e3181d4b3d1be44afd6a472897 (patch)
tree1f8bc8ee150ce78242d3af5359f22c7c3d07c34c /net-dialup
parentapp-editors/neovim-qt: update EAPI 6 -> 8 (diff)
downloadguru-48ebdf539be5c7e3181d4b3d1be44afd6a472897.tar.gz
guru-48ebdf539be5c7e3181d4b3d1be44afd6a472897.tar.bz2
guru-48ebdf539be5c7e3181d4b3d1be44afd6a472897.zip
net-dialup/tio: add 1.38
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/tio-1.38.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
index 676a3b16a..ef23af762 100644
--- a/net-dialup/tio/Manifest
+++ b/net-dialup/tio/Manifest
@@ -1 +1,2 @@
DIST tio-1.37.tar.xz 1804236 BLAKE2B 320ab5955c80551198b24ae9f166a0d41790557755d4cc44149d0aeaabb5a75dfc3e5d29c009b5b985a6788226b63756e4e7588dbb7f658f4b8a8ce99b270bf6 SHA512 207184d297809c7f88185353b55519cf119eed26b5710b644418ef0603d003618c69e593a0f531822c0455a512397cea1b4747a453af5bbb369dad14025b0847
+DIST tio-1.38.tar.xz 1806556 BLAKE2B e8a02e4349b4b4ea27887031fdcce79bd99914b85710a005b1dc5328aea98ec175e6991920d85df7c9acf9c0557dfc3c31005c19c62ca7d28ac7bba08896753f SHA512 d702c907460abd3c15d051f185592d5ec9245734016e299960a4a102724e28208bb21b71cb3cba7919cd2197f338470297034401c7978bcd207195b548e8a2b9
diff --git a/net-dialup/tio/tio-1.38.ebuild b/net-dialup/tio/tio-1.38.ebuild
new file mode 100644
index 000000000..aa1af5f4e
--- /dev/null
+++ b/net-dialup/tio/tio-1.38.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/inih
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}