aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2024-02-13 22:54:59 +0800
committerHuang Rui <vowstar@gmail.com>2024-02-13 22:54:59 +0800
commit586fcb276d9d6a141869f9e5b0507414019f1b95 (patch)
tree35c508ae8b87a6a8e4a7f5d242a07ee13762c4ae /sci-electronics
parentdev-libs/librepo: new package, add 1.17.0 (diff)
downloadguru-586fcb276d9d6a141869f9e5b0507414019f1b95.tar.gz
guru-586fcb276d9d6a141869f9e5b0507414019f1b95.tar.bz2
guru-586fcb276d9d6a141869f9e5b0507414019f1b95.zip
sci-electronics/kactus2: add 3.13.1
Signed-off-by: Huang Rui <vowstar@gmail.com>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kactus2/Manifest1
-rw-r--r--sci-electronics/kactus2/kactus2-3.13.1.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/sci-electronics/kactus2/Manifest b/sci-electronics/kactus2/Manifest
index e63830fff..97d16a6b9 100644
--- a/sci-electronics/kactus2/Manifest
+++ b/sci-electronics/kactus2/Manifest
@@ -1,2 +1,3 @@
DIST kactus2-3.12.0.tar.gz 28154387 BLAKE2B c8e0a982343d3a34f9186bca1778b68b4dfdcd977488751f90d9d5372df96c4f7349c90e15203f66778ee1be399e9e2ddb5342dffe1025754e44604c77c16684 SHA512 d7cef803314262c9fb0b77db88b5d7935203e1484965f475e954bceb1bc56a31ee9867fe1d73959d62a8454238480226df8fbd2d487442bce44fe7476de6d5bb
DIST kactus2-3.13.0.tar.gz 28682844 BLAKE2B 2dc6d6b1ed18d95cce38179c0538c4697c8b2f0de0984fedf0a0b757a7c6c9268e91b9cb09a99c2cdd1913344e928b8d3d665da292d7c47ddf983f92d28142f8 SHA512 750a318fa543f4feaf8176bc9b9bcf244ac3f97d130b6dbe5483e68e7ac30b146c5d9362cdebb4129b62a1fec89a4f3bcfb97822e45930ad05a699ab1ad2f8f5
+DIST kactus2-3.13.1.tar.gz 28686011 BLAKE2B 2abe1d7f6abcfb97f41e293476c200e3d9ba31e32e2b34022d7bbb3007cd2a2c129c73b1414cc422fc7dbc6982636edcd4ad0dc89aff8d352b2e936583d08291 SHA512 9465da2448d54ae3c19aaf5d765b386dd997244ac8385c8e3fddde74807c30e37bdef4d7b56d1610c1c59a1ad10c7c13fe312b53b6263800c9142be7be558049
diff --git a/sci-electronics/kactus2/kactus2-3.13.1.ebuild b/sci-electronics/kactus2/kactus2-3.13.1.ebuild
new file mode 100644
index 000000000..b542e4034
--- /dev/null
+++ b/sci-electronics/kactus2/kactus2-3.13.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit python-r1 qmake-utils xdg
+
+DESCRIPTION="A open source IP-XACT-based tool"
+HOMEPAGE="
+ https://research.tuni.fi/system-on-chip/tools/
+ https://github.com/kactus2/kactus2dev
+"
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}dev.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}dev/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}dev-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-qt/qtbase:6=[cups,gui,network,opengl,widgets,xml]
+ dev-qt/qtsvg:6
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ dev-lang/swig
+ dev-qt/qttools:6[linguist,qdoc]
+"
+
+src_prepare() {
+ default
+ # Fix QA pre-stripped warnings, bug 781674
+ find . -type f -name \*.pro -exec sed -e '$a\\nCONFIG+=nostrip' -i '{}' + || die
+ # Fix bug 854081
+ python_setup
+ sed -e "s|PYTHON_CONFIG=.*|PYTHON_CONFIG=${EPYTHON}-config|" -i .qmake.conf || die
+}
+
+src_configure() {
+ default
+ # Fix bug 854075
+ # Fix bug 854078
+ eqmake6 Kactus2_Solution.pro
+}
+
+src_compile() {
+ default
+ python_compile() {
+ cp -TR "${S}/" "${BUILD_DIR}/" || die
+ # Fix bug 854081
+ python_setup
+ sed -e "s|PYTHON_CONFIG=.*|PYTHON_CONFIG=${EPYTHON}-config|" -i .qmake.conf || die
+ export PYTHON_C_FLAGS="$(python_get_CFLAGS)"
+ export PYTHON_LIBS="$(python_get_LIBS)"
+ pushd "PythonAPI" || die
+ eqmake6 PREFIX="$(python_get_library_path)"
+ emake
+ rm _pythonAPI.so || die
+ cp libPythonAPI.so.1.0.0 _pythonAPI.so || die
+ popd
+ }
+ python_foreach_impl run_in_build_dir python_compile
+}
+
+src_install() {
+ # Can't use default, set INSTALL_ROOT and workaround parallel install bug
+ emake -j1 INSTALL_ROOT="${D}" install
+ python_install() {
+ pushd "PythonAPI" || die
+ python_domodule _pythonAPI.so
+ python_domodule pythonAPI.py
+ popd
+ }
+ python_foreach_impl run_in_build_dir python_install
+}