aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-08-14 14:57:59 +0200
committerArsen Arsenović <arsen@gentoo.org>2023-08-14 14:59:31 +0200
commitb7356b64513fd371e48805e0b91a97509579818b (patch)
tree1e1956132b4a59b0162935e3a8ccfdf658d5551e /sys-boot
parentx11-wm/leftwm: update LICENSE, move src_compile to src_configure (diff)
downloadguru-b7356b64513fd371e48805e0b91a97509579818b.tar.gz
guru-b7356b64513fd371e48805e0b91a97509579818b.tar.bz2
guru-b7356b64513fd371e48805e0b91a97509579818b.zip
sys-boot/limine: add 5.20230811.0
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/limine/Manifest1
-rw-r--r--sys-boot/limine/limine-5.20230811.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-boot/limine/Manifest b/sys-boot/limine/Manifest
index 99bb6acc82..78540593de 100644
--- a/sys-boot/limine/Manifest
+++ b/sys-boot/limine/Manifest
@@ -4,3 +4,4 @@ DIST limine-4.20230529.0.tar.xz 961384 BLAKE2B 3345fb306f4c215719e0839200633e7ed
DIST limine-4.20230530.0.tar.xz 960956 BLAKE2B bf68ac2f360874b56d91fa009efb59faeedd5a834c8be9ed0ccf7e717e6d9e751c2aca7a6e2e0837ee17431e41235e79aeb8a95230791a35c3c82cca9cfeb5b8 SHA512 ab5823c8b34265d3e8d87bfd0bec1623fc0151bae1df9f28dab29acd506105a3d9d171949656fa9a5ae1d1c63ac2a02542552b3c95f072a94adff45081c98fd4
DIST limine-4.20230606.0.tar.xz 963232 BLAKE2B 613a0d5c5893f2cff1398c03a08c50c60b448f73a4b1f568dde0f2de1bea59ac8ecfaa398e5b601c3eea5c0fcea778a88a178fdaa77acd2236de9f56a7da8cc4 SHA512 617d9ad2d0e34222e88fbbec92593d5e7cc5634487b469effefafd94d5c5c3189c5fa5261a83850d79ae7d60f63a460ee4ff0e499a0c833839f3e07af07aec42
DIST limine-4.20230615.0.tar.xz 963720 BLAKE2B a4124be763c84ded9367cffc965ca60c6e4360e870f19342e8feb3d018ed33b26753c105c3dbe1db6580b5760c57ec08858fddb9bb29e9de466c0bbe31752ade SHA512 2d06ff827a6720d6974bdbff88010c08772c4110a2c106bec089333a6b1ea50176a8e43930550af483d0c6fab3606744b6b36fcd930dc660934925ed06faa76a
+DIST limine-5.20230811.0.tar.xz 1289484 BLAKE2B 3044bef68ce62a701df30774d35ce886a6af578e8e1bd943a5524bd9562e8f5709a85800aa5ba4f30a194308b1607a6cea3fedd0951466bf1eef2abb6e462b6c SHA512 6b98ff89efc3e52d2fd36ca1b01818de24ddb512b4936994354ae6604a17738e357ab2a4fcaf81fca97fa8f3499493534fe1e581d8f97ea49c7079d2f5249d2a
diff --git a/sys-boot/limine/limine-5.20230811.0.ebuild b/sys-boot/limine/limine-5.20230811.0.ebuild
new file mode 100644
index 0000000000..5a72ed2ff6
--- /dev/null
+++ b/sys-boot/limine/limine-5.20230811.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Limine is a modern, advanced, and portable BIOS/UEFI multiprotocol bootloader"
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+bios +bios-pxe +bios-cd +cd-efi +uefi32 +uefi64 +uefiaa64"
+
+MY_LLVM_TARGETS="AArch64 ARM X86"
+MY_LLVM_FLAGS="llvm_targets_${MY_LLVM_TARGETS// /(-),llvm_targets_}(-)"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/nasm
+ sys-apps/findutils
+ sys-devel/clang[${MY_LLVM_FLAGS}]
+ sys-devel/lld
+ sys-devel/llvm[${MY_LLVM_FLAGS}]
+
+ cd-efi? ( sys-fs/mtools )
+"
+
+src_configure() {
+ local myconf=(
+ "$(use_enable bios)"
+ "$(use_enable bios-cd)"
+ "$(use_enable bios-pxe)"
+
+ "$(use_enable uefi32 uefi-ia32)"
+ "$(use_enable uefi64 uefi-x86-64)"
+ "$(use_enable uefiaa64 uefi-aarch64)"
+ "$(use_enable cd-efi uefi-cd)"
+ )
+
+ TOOLCHAIN_FOR_TARGET=llvm \
+ econf "${myconf[@]}"
+}